summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-17 16:40:08 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-17 16:40:08 +0000
commitd42fc02c4672fc24bb13cbe5a412b76c16f2d86a (patch)
treea15aa60c643dc5dbf150b6bca2320e1d9dfa0974 /sys-apps/groff
parentkeyworded ~arch for sparc (diff)
downloadgentoo-2-d42fc02c4672fc24bb13cbe5a412b76c16f2d86a.tar.gz
gentoo-2-d42fc02c4672fc24bb13cbe5a412b76c16f2d86a.tar.bz2
gentoo-2-d42fc02c4672fc24bb13cbe5a412b76c16f2d86a.zip
Version bump #254964 by Lars (Polynomial-C).
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog9
-rw-r--r--sys-apps/groff/groff-1.20.1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 6a7aedb4450f..508e8aa6a3eb 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.82 2008/06/24 11:02:02 mduft Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.83 2009/01/17 16:40:08 vapier Exp $
+
+*groff-1.20.1 (17 Jan 2009)
+
+ 17 Jan 2009; Mike Frysinger <vapier@gentoo.org> +groff-1.20.1.ebuild:
+ Version bump #254964 by Lars (Polynomial-C).
24 Jun 2008; Markus Duft <mduft@gentoo.org> groff-1.19.2-r3.ebuild:
added missing dependencies to X11 libraries (bug #219003)
diff --git a/sys-apps/groff/groff-1.20.1.ebuild b/sys-apps/groff/groff-1.20.1.ebuild
new file mode 100644
index 000000000000..7ba4f5cb1e3d
--- /dev/null
+++ b/sys-apps/groff/groff-1.20.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1.ebuild,v 1.1 2009/01/17 16:40:08 vapier Exp $
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz
+ cjk? ( mirror://gentoo/groff-1.19.2-japanese.patch.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk X"
+
+DEPEND=">=sys-apps/texinfo-4.7-r1
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXaw
+ x11-libs/libSM
+ x11-libs/libICE
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+
+ # Make sure we can cross-compile this puppy
+ if tc-is-cross-compiler ; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=/usr/bin/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=/usr/bin/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
+ contrib/mom/Makefile.sub \
+ doc/Makefile.in \
+ doc/Makefile.sub || die "cross-compile sed failed"
+ fi
+
+ if use cjk ; then
+ epatch "${WORKDIR}"/groff-1.19.2-japanese.patch #134377
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+# tc-export CC CXX
+
+ econf \
+ --with-appresdir=/usr/share/X11/app-defaults \
+ $(use_with X x) \
+ $(use_enable cjk japanese) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # The following links are required for man #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ dodoc BUG-REPORT ChangeLog MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}