summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 03:42:44 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 03:42:44 +0000
commit13ba070fb85c7a18edf9c14267eb1ef164f9760c (patch)
treebf963d8da0ade434be45f19057c4bf56c87abb7a /sys-apps/gtkpbbuttons
parentlintool fixes for #9258 (diff)
downloadgentoo-2-13ba070fb85c7a18edf9c14267eb1ef164f9760c.tar.gz
gentoo-2-13ba070fb85c7a18edf9c14267eb1ef164f9760c.tar.bz2
gentoo-2-13ba070fb85c7a18edf9c14267eb1ef164f9760c.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/gtkpbbuttons')
-rw-r--r--sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild13
-rw-r--r--sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild6
2 files changed, 4 insertions, 15 deletions
diff --git a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
index c4d78ff7d748..fd815290d20a 100644
--- a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
+++ b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.10 2002/10/04 06:25:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.4.6b.ebuild,v 1.11 2002/10/19 03:42:44 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gtkpbbuttons is a PPC-only program to monitor special Powerbook/iBook keys in Linux"
@@ -11,22 +11,14 @@ SLOT="0"
LICENSE="GPL-2"
DEPEND="x11-libs/gtk+ media-libs/audiofile sys-apps/pbbuttonsd"
-
-pkg_setup() {
- if [ ${ARCH} != "ppc" ] ; then
- eerror "Sorry, this is a PPC only package."
- die "Sorry, this as a PPC only pacakge."
- fi
-}
+RDEPEND="${DEPEND}"
src_compile() {
-
./configure --prefix=/usr || die "sorry, ppc-only package"
make || die "sorry, gtkpbbuttons compile failed"
}
src_install() {
-
make \
prefix=${D}/usr \
mandir={D}/usr/share/man \
@@ -34,5 +26,4 @@ src_install() {
install || die "sorry, failed to install gtkpbbuttons"
dodoc README COPYING
-
}
diff --git a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild
index 3f2d6be969db..511283af39f6 100644
--- a/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild
+++ b/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild,v 1.1 2002/10/17 08:08:57 kain Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gtkpbbuttons/gtkpbbuttons-0.5.2.ebuild,v 1.2 2002/10/19 03:42:44 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="gtkpbbuttons is a PPC-only program to monitor special Powerbook/iBook keys in Linux"
@@ -11,15 +11,14 @@ SLOT="0"
LICENSE="GPL-2"
DEPEND="x11-libs/gtk+ media-libs/audiofile >=sys-apps/pbbuttonsd-0.5"
+RDEPEND="${DEPEND}"
src_compile() {
-
./configure --prefix=/usr || die "sorry, gtkpbbuttons configure failed"
make || die "sorry, gtkpbbuttons compile failed"
}
src_install() {
-
make \
prefix=${D}/usr \
mandir={D}/usr/share/man \
@@ -27,5 +26,4 @@ src_install() {
install || die "sorry, failed to install gtkpbbuttons"
dodoc README COPYING
-
}