summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-05 17:29:55 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-05 17:29:55 +0000
commit2284a05f88d8869fd108f5d62279c2a4b236be09 (patch)
tree1e2cf1e243e6272b72e01ead0e94d42ad006a26d /sys-apps/hal
parentadded >=app-i18n/scim-anthy-1.3.0 (diff)
downloadgentoo-2-2284a05f88d8869fd108f5d62279c2a4b236be09.tar.gz
gentoo-2-2284a05f88d8869fd108f5d62279c2a4b236be09.tar.bz2
gentoo-2-2284a05f88d8869fd108f5d62279c2a4b236be09.zip
Re-work acpi USE flag usage. Add pam USE flag for sys-auth/consolekit. Remove mactel USE flag since it will auto build and that's how it should. Added linux-sources depend on having a Linux kernel. Check for Linux or FreeBSD kernel to support both Gentoo/Linux and Gentoo/FreeBSD. Add building of dell utilies based on dell USE flag so we don't have an automagical depend. 2 upstream fixes. One for duplicate acpi messages. One for a possible crasher.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/ChangeLog14
-rw-r--r--sys-apps/hal/files/0.5.9/02_acpi_repeated_property_change.patch39
-rw-r--r--sys-apps/hal/files/0.5.9/03_crasher_fix_fail_to_return_value.patch19
-rw-r--r--sys-apps/hal/files/0.5.9/series2
-rw-r--r--sys-apps/hal/hal-0.5.9.ebuild33
5 files changed, 100 insertions, 7 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index e2bb17d157c0..0d97cd03a4e3 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.145 2007/04/05 02:18:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.146 2007/04/05 17:29:55 cardoe Exp $
+
+ 05 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
+ +files/0.5.9/02_acpi_repeated_property_change.patch,
+ +files/0.5.9/03_crasher_fix_fail_to_return_value.patch,
+ files/0.5.9/series, hal-0.5.9.ebuild:
+ Re-work acpi USE flag usage. Add pam USE flag for sys-auth/consolekit.
+ Remove mactel USE flag since it will auto build and that's how it should.
+ Added linux-sources depend on having a Linux kernel. Check for Linux or
+ FreeBSD kernel to support both Gentoo/Linux and Gentoo/FreeBSD. Add building
+ of dell utilies based on dell USE flag so we don't have an automagical
+ depend. 2 upstream fixes. One for duplicate acpi messages. One for a
+ possible crasher.
05 Apr 2007; Doug Goldstein <cardoe@gentoo.org> +files/0.5.9-hald.rc,
+files/0.5.9/series, -files/hald, hal-0.5.9.ebuild:
diff --git a/sys-apps/hal/files/0.5.9/02_acpi_repeated_property_change.patch b/sys-apps/hal/files/0.5.9/02_acpi_repeated_property_change.patch
new file mode 100644
index 000000000000..69d415af04be
--- /dev/null
+++ b/sys-apps/hal/files/0.5.9/02_acpi_repeated_property_change.patch
@@ -0,0 +1,39 @@
+From: Danny Kukawka <danny.kukawka@web.de>
+Date: Wed, 4 Apr 2007 22:48:10 +0000 (-0400)
+Subject: fix problem with repeated property-changed signals
+X-Git-Tag: HAL_0_2
+X-Git-Url: http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=3ede8e2ce38e48ba7c292ed17d348f6e810db2c1
+
+fix problem with repeated property-changed signals
+
+> On Mittwoch, 4. April 2007, Richard Hughes wrote:
+> > With git I'm getting the following when I remove AC:
+> >
+> > 15:56:02.865: acpi_ACAD property ac_adapter.present = false
+> > 15:56:03.041: acpi_ACAD property ac_adapter.present = false
+> > 15:56:03.048: acpi_BAT1 property battery.charge_level.percentage = 96
+> > (0x60) 15:56:03.051: acpi_BAT1 property battery.charge_level.percentage =
+> > 96 (0x60)
+> >
+> > acpi_listen seems to think that there is one event from either device,
+> > so I'm unsure what the problem is here.
+>
+> I can confirm this, I take a look at the problem. It is IMO something in
+> the acpi code, could not see this atm for other devices.
+
+This is a general problem. The signal for device_property_changed is listed
+twice in hald.c in function hald_get_gdl().
+---
+
+--- a/hald/hald.c
++++ b/hald/hald.c
+@@ -203,9 +203,6 @@ hald_get_gdl (void)
+ "device_capability_added",
+ G_CALLBACK (gdl_capability_added), NULL);
+ g_signal_connect (global_device_list,
+- "device_property_changed",
+- G_CALLBACK (gdl_property_changed), NULL);
+- g_signal_connect (global_device_list,
+ "device_lock_acquired",
+ G_CALLBACK (gdl_lock_acquired), NULL);
+ g_signal_connect (global_device_list,
diff --git a/sys-apps/hal/files/0.5.9/03_crasher_fix_fail_to_return_value.patch b/sys-apps/hal/files/0.5.9/03_crasher_fix_fail_to_return_value.patch
new file mode 100644
index 000000000000..ec08b92b0224
--- /dev/null
+++ b/sys-apps/hal/files/0.5.9/03_crasher_fix_fail_to_return_value.patch
@@ -0,0 +1,19 @@
+From: David Zeuthen <davidz@redhat.com>
+Date: Thu, 5 Apr 2007 05:04:53 +0000 (-0400)
+Subject: fix a potential crasher
+X-Git-Tag: HAL_0_2
+X-Git-Url: http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=7ce45a77001031a0d7777d7e1e5269256791b6f1
+
+fix a potential crasher
+---
+
+--- a/hald/hald_dbus.c
++++ b/hald/hald_dbus.c
+@@ -2161,6 +2161,7 @@ device_is_caller_locked_out (DBusConnect
+ /* only allow HAL helpers / privileged users to ask this question */
+ if (!local_interface && !access_check_message_caller_is_root_or_hal (ci_tracker, message)) {
+ raise_permission_denied (connection, message, "IsCallerLockedOut: not privileged");
++ return DBUS_HANDLER_RESULT_HANDLED;
+ }
+
+ dbus_error_init (&error);
diff --git a/sys-apps/hal/files/0.5.9/series b/sys-apps/hal/files/0.5.9/series
index c1fdfb94d58c..7bf644648466 100644
--- a/sys-apps/hal/files/0.5.9/series
+++ b/sys-apps/hal/files/0.5.9/series
@@ -1 +1,3 @@
01_luks_mount_fix.patch
+02_acpi_repeated_property_change.patch
+03_crasher_fix_fail_to_return_value.patch
diff --git a/sys-apps/hal/hal-0.5.9.ebuild b/sys-apps/hal/hal-0.5.9.ebuild
index 413e9e833ad7..19fb0767813e 100644
--- a/sys-apps/hal/hal-0.5.9.ebuild
+++ b/sys-apps/hal/hal-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.3 2007/04/05 02:18:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.4 2007/04/05 17:29:55 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -11,13 +11,13 @@ SRC_URI="http://people.freedesktop.org/~david/dist/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.0 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="acpi crypt debug dell disk-partition doc mactel pcmcia selinux"
+IUSE="acpi crypt debug dell disk-partition doc pam pcmcia selinux"
RDEPEND=">=dev-libs/glib-2.6
>=dev-libs/dbus-glib-0.61
>=sys-fs/udev-104
>=sys-apps/util-linux-2.12r-r1
- >=sys-kernel/linux-headers-2.6.17
+ kernel_linux? ( >=sys-kernel/linux-headers-2.6.17 )
>=dev-libs/expat-1.95.8
>=sys-apps/pciutils-2.2.3
>=dev-libs/libusb-0.1.10a
@@ -28,7 +28,8 @@ RDEPEND=">=dev-libs/glib-2.6
dell? ( >=sys-libs/libsmbios-0.13.4 )
disk-partition? ( >=sys-apps/parted-1.7.1 )
crypt? ( >=sys-fs/cryptsetup-luks-1.0.1 )
- selinux? ( sys-libs/libselinux )"
+ selinux? ( sys-libs/libselinux )
+ pam? ( sys-auth/consolekit )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -92,23 +93,43 @@ src_unpack() {
}
src_compile() {
+ local backend=""
+ local acpi=""
+
# TODO :: policykit should have a pam useflag
append-flags -rdynamic
+ if use kernel_linux ; then
+ backend="linux"
+ elif use kernel_FreeBSD ; then
+ backend="freebsd"
+ else
+ eerror "Invalid backend"
+ fi
+
+ if use acpi ; then
+ acpi="--enable-acpi-toshiba --enable-acpi-ibm"
+ else
+ acpi="--disable-acpi-proc --disable-acpi-acpid"
+ fi
+
econf --disable-policy-kit \
--with-doc-dir=/usr/share/doc/${PF} \
--with-os-type=gentoo \
--with-pid-file=/var/run/hald.pid \
--with-hwdata=/usr/share/misc \
--enable-hotplug-map \
+ --enable-man-pages \
+ --with-backend=${backend} \
$(use_enable debug verbose-mode) \
+ $(use_with dell dell-backlight) \
$(use_enable disk-partition parted) \
$(use_enable pcmcia pcmcia-support) \
- $(use_enable acpi acpi-proc) \
$(use_enable doc docbook-docs) \
$(use_enable doc doxygen-docs) \
- $(use_with mactel macbookpro) \
$(use_enable selinux) \
+ $(use_enable pam console-kit) \
+ ${acpi} \
|| die "configure failed"
emake || die "make failed"