summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-17 17:20:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-17 17:20:53 +0000
commit7932568ad422f5f2ff2aab44d896cbac0e7eff31 (patch)
treef922fb93212df284a16560c8852ab0b5900cb2be /sys-apps/haveged
parentStable for HPPA (bug #386883). (diff)
downloadgentoo-2-7932568ad422f5f2ff2aab44d896cbac0e7eff31.tar.gz
gentoo-2-7932568ad422f5f2ff2aab44d896cbac0e7eff31.tar.bz2
gentoo-2-7932568ad422f5f2ff2aab44d896cbac0e7eff31.zip
Version bump; add an OpenRC-based init script that actually checks the haveged started status.
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/haveged')
-rw-r--r--sys-apps/haveged/ChangeLog9
-rw-r--r--sys-apps/haveged/files/haveged-init.d.214
-rw-r--r--sys-apps/haveged/haveged-1.2.ebuild29
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-apps/haveged/ChangeLog b/sys-apps/haveged/ChangeLog
index bfad9286953a..fe393430ea61 100644
--- a/sys-apps/haveged/ChangeLog
+++ b/sys-apps/haveged/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/haveged
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/ChangeLog,v 1.6 2011/08/06 12:23:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/ChangeLog,v 1.7 2011/10/17 17:20:53 flameeyes Exp $
+
+*haveged-1.2 (17 Oct 2011)
+
+ 17 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org> +haveged-1.2.ebuild,
+ +files/haveged-init.d.2:
+ Version bump; add an OpenRC-based init script that actually checks the
+ haveged started status.
06 Aug 2011; Markus Meier <maekke@gentoo.org> haveged-1.1.ebuild:
x86 stable, bug #368699
diff --git a/sys-apps/haveged/files/haveged-init.d.2 b/sys-apps/haveged/files/haveged-init.d.2
new file mode 100644
index 000000000000..136094cefe37
--- /dev/null
+++ b/sys-apps/haveged/files/haveged-init.d.2
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/files/haveged-init.d.2,v 1.1 2011/10/17 17:20:53 flameeyes Exp $
+
+command="/usr/sbin/${SVCNAME}"
+command_args="-r 0 ${HAVEGED_OPTS}"
+pidfile=/var/run/${SVCNAME}.pid
+
+depend() {
+ provide entropy
+}
+
+# vim:ft=gentoo-init-d:
diff --git a/sys-apps/haveged/haveged-1.2.ebuild b/sys-apps/haveged/haveged-1.2.ebuild
new file mode 100644
index 000000000000..8ca76739986b
--- /dev/null
+++ b/sys-apps/haveged/haveged-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/haveged/haveged-1.2.ebuild,v 1.1 2011/10/17 17:20:53 flameeyes Exp $
+
+EAPI=4
+DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
+HOMEPAGE="http://www.issihosts.com/haveged/"
+SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+RDEPEND="sys-apps/openrc"
+
+src_configure() {
+ econf --bindir=/usr/sbin --enable-nistest
+}
+
+src_install() {
+ default
+ # This is a RedHat init script
+ rm -rf "${D}"/etc/init.d/haveged
+ # Install gentoo ones instead
+ newinitd "${FILESDIR}"/haveged-init.d.2 haveged
+ newconfd "${FILESDIR}"/haveged-conf.d haveged
+}