summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-19 22:28:27 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-19 22:28:27 +0000
commit3bb94abc1ae1eb963aea3e4f6e9094212fffdcb3 (patch)
tree7aa7e99bd5127f9998b0fe67ffe4ca59bfdef3e9 /sys-apps/hotplug
parentAddeed ppc to KEYWORDS. (diff)
downloadgentoo-2-3bb94abc1ae1eb963aea3e4f6e9094212fffdcb3.tar.gz
gentoo-2-3bb94abc1ae1eb963aea3e4f6e9094212fffdcb3.tar.bz2
gentoo-2-3bb94abc1ae1eb963aea3e4f6e9094212fffdcb3.zip
add new hotplug ebuild files and last patches
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20020401-r11
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-200208261
-rw-r--r--sys-apps/hotplug/hotplug-20020401-r1.ebuild54
-rw-r--r--sys-apps/hotplug/hotplug-20020826.ebuild54
4 files changed, 110 insertions, 0 deletions
diff --git a/sys-apps/hotplug/files/digest-hotplug-20020401-r1 b/sys-apps/hotplug/files/digest-hotplug-20020401-r1
new file mode 100644
index 000000000000..d02541276722
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20020401-r1
@@ -0,0 +1 @@
+MD5 50792a87d2eea046616d815e03d1af6b hotplug-2002_04_01.tar.gz 36984
diff --git a/sys-apps/hotplug/files/digest-hotplug-20020826 b/sys-apps/hotplug/files/digest-hotplug-20020826
new file mode 100644
index 000000000000..9a8988c092a2
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20020826
@@ -0,0 +1 @@
+MD5 eb3e3aacfe072e7bd31a4e01fd8af2e0 hotplug-2002_08_26.tar.gz 37805
diff --git a/sys-apps/hotplug/hotplug-20020401-r1.ebuild b/sys-apps/hotplug/hotplug-20020401-r1.ebuild
new file mode 100644
index 000000000000..ac7264e816de
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20020401-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020401-r1.ebuild,v 1.1 2002/10/19 22:28:27 zwelch Exp $
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=`echo ${P}|sed 's/-\(....\)\(..\)\(..\)/-\1_\2_\3/'`
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/linux-hotplug/${MY_P}.tar.gz"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+KEYWORDS="x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND="virtual/glibc
+ >=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ patch -p0 < ${FILESDIR}/${P}-pci.rc-gentoo.diff
+ patch -p0 < ${FILESDIR}/${P}-usb.rc-gentoo.diff
+ patch -p3 < ${FILESDIR}/${P}-usb.agent-gentoo.diff
+ patch -p3 < ${FILESDIR}/${P}-net.agent-gentoo.diff
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.conf usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
diff --git a/sys-apps/hotplug/hotplug-20020826.ebuild b/sys-apps/hotplug/hotplug-20020826.ebuild
new file mode 100644
index 000000000000..8ebdf87ef4e7
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20020826.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020826.ebuild,v 1.1 2002/10/19 22:28:27 zwelch Exp $
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=`echo ${P}|sed 's/-\(....\)\(..\)\(..\)/-\1_\2_\3/'`
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/linux-hotplug/${MY_P}.tar.gz"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND="virtual/glibc
+ >=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ patch -p0 < ${FILESDIR}/${P}-pci.rc-gentoo.diff
+ patch -p0 < ${FILESDIR}/${P}-usb.rc-gentoo.diff
+ patch -p3 < ${FILESDIR}/${P}-usb.agent-gentoo.diff
+ patch -p3 < ${FILESDIR}/${P}-net.agent-gentoo.diff
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.conf usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}