summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-01-03 21:58:44 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-01-03 21:58:44 +0000
commit447e0835b44781f3fb615eb642f227e04a23fc55 (patch)
tree3bd2a28d2da65437d099052cbac135660cc9a87e /sys-apps/i2c/i2c-2.9.0.ebuild
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-447e0835b44781f3fb615eb642f227e04a23fc55.tar.gz
gentoo-2-447e0835b44781f3fb615eb642f227e04a23fc55.tar.bz2
gentoo-2-447e0835b44781f3fb615eb642f227e04a23fc55.zip
Backport upstream CVS fix to allow lm-sensors-2.9.0 to play nice with 2.4 kernels.
Diffstat (limited to 'sys-apps/i2c/i2c-2.9.0.ebuild')
-rw-r--r--sys-apps/i2c/i2c-2.9.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/i2c/i2c-2.9.0.ebuild b/sys-apps/i2c/i2c-2.9.0.ebuild
index 0b53c02a0d2c..b633f2258069 100644
--- a/sys-apps/i2c/i2c-2.9.0.ebuild
+++ b/sys-apps/i2c/i2c-2.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.9.0.ebuild,v 1.1 2005/01/01 22:12:04 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.9.0.ebuild,v 1.2 2005/01/03 21:58:44 plasmaroo Exp $
inherit eutils toolchain-funcs
@@ -15,6 +15,11 @@ IUSE=""
DEPEND=""
+src_unpack () {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}.fix.patch
+}
+
src_compile () {
if [ "$LINUX" != "" ]; then
einfo "Cross-compiling using:- $LINUX"