summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-11 19:02:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-11 19:02:28 +0000
commitf3d612d285412cfa7a9cd3ccbfbf8d609cac2ef6 (patch)
tree44e4dd8c51283d62576446c2df4c25ed8e1ad876 /sys-apps/initng
parentold (diff)
downloadgentoo-2-f3d612d285412cfa7a9cd3ccbfbf8d609cac2ef6.tar.gz
gentoo-2-f3d612d285412cfa7a9cd3ccbfbf8d609cac2ef6.tar.bz2
gentoo-2-f3d612d285412cfa7a9cd3ccbfbf8d609cac2ef6.zip
updates from Thomas Kear #135904
Diffstat (limited to 'sys-apps/initng')
-rw-r--r--sys-apps/initng/initng-9999.ebuild58
1 files changed, 38 insertions, 20 deletions
diff --git a/sys-apps/initng/initng-9999.ebuild b/sys-apps/initng/initng-9999.ebuild
index abe828054a37..a93dba20ec47 100644
--- a/sys-apps/initng/initng-9999.ebuild
+++ b/sys-apps/initng/initng-9999.ebuild
@@ -1,46 +1,64 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.8 2006/02/27 00:47:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.9 2006/06/11 19:02:28 vapier Exp $
-ESVN_REPO_URI="http://svn.initng.thinktux.net/initng/trunk"
+ESVN_REPO_URI="http://svn.initng.org/initng/trunk"
ESVN_PROJECT="initng"
inherit subversion
DESCRIPTION="A next generation init replacement"
-HOMEPAGE="http://initng.thinktux.net/"
+HOMEPAGE="http://initng.org/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-*"
-IUSE="debug"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.1"
S=${WORKDIR}/${PN}
-src_unpack() {
- subversion_src_unpack
- emake -f Makefile.cvs || die "autogen failed"
+plugin_warning() {
+ if [[ -z ${INITNG_PLUGINS} ]] ; then
+ einfo "If you want to customize the list of initng plugins, please"
+ einfo "set the INITNG_PLUGINS variable in your make.conf."
+ einfo "See http://www.initng.org/wiki/Documents_Plugins for a list of"
+ einfo "valid plugins for you to choose from."
+ fi
+}
+
+pkg_setup() {
+ plugin_warning
}
src_compile() {
- econf \
- --prefix=/ \
- $(use_enable debug) \
- --with-doc-dir=/usr/share/doc/${PF} \
- || die
+ local x default_opts valid_opts cmake_opts=""
+ valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ default_opts=$(sed -n '/^OPTION(.*ON)$/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ INITNG_PLUGINS=$(echo ${INITNG_PLUGINS} | tr '[:lower:]' '[:upper:]')
+ INITNG_PLUGINS=${INITNG_PLUGINS:-${default_opts}}
+ for x in ${valid_opts} ; do
+ if hasq ${x} ${INITNG_PLUGINS} || hasq ${x#BUILD_} ${INITNG_PLUGINS} ; then
+ cmake_opts="${cmake_opts} -D${x}=ON"
+ else
+ cmake_opts="${cmake_opts} -D${x}=OFF"
+ fi
+ done
+ cmake -DCMAKE_INSTALL_PREFIX=/ ${cmake_opts} || die
emake || die
}
src_install() {
- make install DESTDIR="${D}" || die
- # Dont need libtool linker scripts, so punt em
- find "${D}" -name '*.la' -exec rm {} \;
- # other packages install these
- rm "${D}"/sbin/{{ifplugd,wpa_cli}.action} || die
- dodoc README FAQ AUTHORS ChangeLog NEWS TEMPLATE_HEADER TODO
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.a' -exec rm "{}" \;
+ dodoc AUTHORS ChangeLog NEWS README TODO
}
pkg_postinst() {
- einfo "remember to add init=/sbin/initng in your grub or lilo config"
- einfo "to use initng Happy testing."
+ plugin_warning
+ einfo "Remember to add init=/sbin/initng in your grub or lilo config"
+ einfo " in order to use initng. Happy testing!"
}