summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-02-18 12:26:22 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-02-18 12:26:22 +0000
commit508155374cafbc315aefaffc66c2ca25a1de5e37 (patch)
tree93bc73c22febffdc548ef7d4ccae17bf9dd97107 /sys-apps/install-xattr
parentScanner: don't pass certain debug level flags to cpp (from 'master'), drop old (diff)
downloadgentoo-2-508155374cafbc315aefaffc66c2ca25a1de5e37.tar.gz
gentoo-2-508155374cafbc315aefaffc66c2ca25a1de5e37.tar.bz2
gentoo-2-508155374cafbc315aefaffc66c2ca25a1de5e37.zip
Add some || die.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/install-xattr')
-rw-r--r--sys-apps/install-xattr/ChangeLog8
-rw-r--r--sys-apps/install-xattr/install-xattr-0.4.ebuild8
-rw-r--r--sys-apps/install-xattr/install-xattr-9999.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/sys-apps/install-xattr/ChangeLog b/sys-apps/install-xattr/ChangeLog
index 39a107962427..03a548da9f34 100644
--- a/sys-apps/install-xattr/ChangeLog
+++ b/sys-apps/install-xattr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/install-xattr
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.24 2014/10/13 02:29:36 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.25 2015/02/18 12:26:22 blueness Exp $
+
+ 18 Feb 2015; Anthony G. Basile <blueness@gentoo.org> install-xattr-0.4.ebuild,
+ install-xattr-9999.ebuild:
+ Add some || die.
*install-xattr-0.4 (13 Oct 2014)
diff --git a/sys-apps/install-xattr/install-xattr-0.4.ebuild b/sys-apps/install-xattr/install-xattr-0.4.ebuild
index 4cdc20d75667..49db1609c52c 100644
--- a/sys-apps/install-xattr/install-xattr-0.4.ebuild
+++ b/sys-apps/install-xattr/install-xattr-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-0.4.ebuild,v 1.1 2014/10/13 02:29:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-0.4.ebuild,v 1.2 2015/02/18 12:26:22 blueness Exp $
EAPI=5
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
@@ -27,14 +27,14 @@ src_prepare() {
src_compile() {
if [[ ${PV} == "9999" ]] ; then
- cd "${WORKDIR}/${P}/misc/${PN}"
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
fi
default
}
src_install() {
if [[ ${PV} == "9999" ]] ; then
- cd "${WORKDIR}/${P}/misc/${PN}"
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
fi
default
}
diff --git a/sys-apps/install-xattr/install-xattr-9999.ebuild b/sys-apps/install-xattr/install-xattr-9999.ebuild
index 58e9dc31ba2a..6d6c6f212094 100644
--- a/sys-apps/install-xattr/install-xattr-9999.ebuild
+++ b/sys-apps/install-xattr/install-xattr-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-9999.ebuild,v 1.5 2014/10/13 02:29:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-9999.ebuild,v 1.6 2015/02/18 12:26:22 blueness Exp $
EAPI=5
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
@@ -27,14 +27,14 @@ src_prepare() {
src_compile() {
if [[ ${PV} == "9999" ]] ; then
- cd "${WORKDIR}/${P}/misc/${PN}"
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
fi
default
}
src_install() {
if [[ ${PV} == "9999" ]] ; then
- cd "${WORKDIR}/${P}/misc/${PN}"
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
fi
default
}