summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-04 09:46:36 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-04 09:46:36 +0000
commit930b37f37eba4ff3304a9fe1c5b919f6a485033f (patch)
tree01d4c39949a4ea47238aa4c29cee4d1c5b3543be /sys-apps/iproute
parentAdded bluebar/kroller combination (diff)
downloadgentoo-2-930b37f37eba4ff3304a9fe1c5b919f6a485033f.tar.gz
gentoo-2-930b37f37eba4ff3304a9fe1c5b919f6a485033f.tar.bz2
gentoo-2-930b37f37eba4ff3304a9fe1c5b919f6a485033f.zip
Updated debian patch
Diffstat (limited to 'sys-apps/iproute')
-rw-r--r--sys-apps/iproute/ChangeLog7
-rw-r--r--sys-apps/iproute/files/digest-iproute-20010824-r32
-rw-r--r--sys-apps/iproute/iproute-20010824-r3.ebuild76
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-apps/iproute/ChangeLog b/sys-apps/iproute/ChangeLog
index f1eff4422beb..4d166d74ef00 100644
--- a/sys-apps/iproute/ChangeLog
+++ b/sys-apps/iproute/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/iproute
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.17 2003/04/17 15:33:42 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.18 2003/05/04 09:46:36 aliz Exp $
+
+*iproute-20010824-r3 (04 May 2003)
+
+ 04 May 2003; Daniel Ahlberg <aliz@gentoo.org> iproute-20010824-r3.ebuild :
+ Updated to latest Debian patch which includes htb3.
27 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> iproute-20010824-r2.ebuild :
Move binaries to / instead of /usr. Closes #15430.
diff --git a/sys-apps/iproute/files/digest-iproute-20010824-r3 b/sys-apps/iproute/files/digest-iproute-20010824-r3
new file mode 100644
index 000000000000..ecbc0df59073
--- /dev/null
+++ b/sys-apps/iproute/files/digest-iproute-20010824-r3
@@ -0,0 +1,2 @@
+MD5 b05a4e375d9468be3a1dd3f0e83daee8 iproute2-2.4.7-now-ss010824.tar.gz 140139
+MD5 4ce3890725f29d1492e887bb4eed8983 iproute_20010824-9.diff.gz 29910
diff --git a/sys-apps/iproute/iproute-20010824-r3.ebuild b/sys-apps/iproute/iproute-20010824-r3.ebuild
new file mode 100644
index 000000000000..056cd178f213
--- /dev/null
+++ b/sys-apps/iproute/iproute-20010824-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824-r3.ebuild,v 1.1 2003/05/04 09:46:36 aliz Exp $
+
+inherit eutils
+
+IUSE=""
+
+S=${WORKDIR}/iproute2
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/iproute2-2.4.7-now-ss010824.tar.gz
+ http://ftp.debian.org/debian/pool/main/i/iproute/${P/-/_}-9.diff.gz"
+HOMEPAGE="http://www.worldbank.ro/ip-routing/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="virtual/linux-sources"
+
+pkg_setup() {
+ # Make sure kernel headers are really available
+ check_KV
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Our patch does two things for us; First, it syncs up with Debian's
+ # iproute 20010824-9 package; Secondly, it adds htb3 support. The Debian
+ # patch tweaks the iproute compile so that we use an included pkt_sched.h
+ # header rather than looking at the one in /usr/src/linux/include/linux.
+ # This allows us to always enable HTB3 without compile problems; however,
+ # other parts of the source tree are still dependent upon having a kernel
+ # source tree in /usr/src/linux.
+
+ epatch ${WORKDIR}/${P/-/_}-9.diff
+
+ # why was this commented out? were the programs segfaulting/not working?
+ # they seem ok here when i compile with optimisations, so im reenabling
+ # this patch. if theres problems, will glady change back. ~woodchip
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:g" \
+ -e "s:-Werror::g" Makefile.orig > Makefile
+
+ # this next thing is required to enable diffserv
+ # (ATM support doesn't compile right now)
+
+ cp Config Config.orig
+ sed -e 's:DIFFSERV=n:DIFFSERV=y:g' \
+ -e 's:ATM=y:ATM=n:g' Config.orig > Config
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /
+ cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc ; dosbin tc
+ cd ${S} ; dodoc README* RELNOTES
+
+ #install Debian man pages
+ doman ${S}/debian/*.[1-9]
+
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+ if [ "`use tetex`" ] ; then
+ docinto ps ; dodoc doc/*.ps
+ fi
+}