summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-21 19:07:25 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-21 19:07:25 +0000
commit75bceb06cdaf49c335808166eea0179e0d75ea4e (patch)
tree4e15dcd8be284b90587f02fb11355afb0e1df6b3 /sys-apps/irqbalance
parentStable on IA64, bug 156662. (diff)
downloadgentoo-2-75bceb06cdaf49c335808166eea0179e0d75ea4e.tar.gz
gentoo-2-75bceb06cdaf49c335808166eea0179e0d75ea4e.tar.bz2
gentoo-2-75bceb06cdaf49c335808166eea0179e0d75ea4e.zip
Drop initd checks as irqbalance itself does it #162975 by J.Taimr.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'sys-apps/irqbalance')
-rw-r--r--sys-apps/irqbalance/ChangeLog6
-rw-r--r--sys-apps/irqbalance/files/irqbalance.confd15
-rwxr-xr-xsys-apps/irqbalance/files/irqbalance.init19
-rw-r--r--sys-apps/irqbalance/irqbalance-0.55.ebuild3
4 files changed, 23 insertions, 20 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index abcc4e70fd80..e6f19f004cd9 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/irqbalance
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.15 2007/01/09 04:13:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.16 2007/01/21 19:07:25 vapier Exp $
+
+ 21 Jan 2007; Mike Frysinger <vapier@gentoo.org> +files/irqbalance.confd,
+ files/irqbalance.init, irqbalance-0.55.ebuild:
+ Drop initd checks as irqbalance itself does it #162975 by J.Taimr.
09 Jan 2007; Mike Frysinger <vapier@gentoo.org> files/irqbalance.init:
Abort loading on uniproc/dualcore machines. Only want to run on real SMP
diff --git a/sys-apps/irqbalance/files/irqbalance.confd b/sys-apps/irqbalance/files/irqbalance.confd
new file mode 100644
index 000000000000..152dd7988652
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance.confd
@@ -0,0 +1,15 @@
+# /etc/conf.d/irqbalance: config file for /etc/init.d/irqbalance
+# These are envvars used by irqbalance itself. For more info,
+# please see the irqbalance manpage.
+
+# Run irqbalance once and then exit
+#IRQBALANCE_ONESHOT="0"
+
+# Include debug messages in output
+#IRQBALANCE_DEBUG="0"
+
+# List of cpus to not include in balancing
+#IRQBALANCE_BANNED_CPUS=""
+
+# List of interrupts to not include in balancing
+#IRQBALANCE_BANNED_INTERRUPTS=""
diff --git a/sys-apps/irqbalance/files/irqbalance.init b/sys-apps/irqbalance/files/irqbalance.init
index f311b2c22569..18b051931238 100755
--- a/sys-apps/irqbalance/files/irqbalance.init
+++ b/sys-apps/irqbalance/files/irqbalance.init
@@ -1,31 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/files/irqbalance.init,v 1.2 2007/01/09 04:13:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/files/irqbalance.init,v 1.3 2007/01/21 19:07:25 vapier Exp $
depend() {
need localmount
after bootmisc
}
-checkconfig() {
- # irqbalance only makes sense to run on smp machines
- # where each cpu has its own cache ... so if you're
- # just running a dual core machine, you've got shared
- # cache, so we'll abort here.
- local physical_ids=$(grep -s '^physical id[[:space:]]*:' /proc/cpuinfo | sort -u | wc -l)
- [[ ${physical_ids} -gt 1 ]] && return 0
- [[ ${physical_ids} -eq 1 ]] && return 1
- local processors=$(grep -s '^processor[[:space:]]*:' /proc/cpuinfo | sort -u | wc -l)
- [[ ${processors} -gt 1 ]] && return 0
-}
-
start() {
- if ! checkconfig ; then
- eerror "irqbalance: your machine lacks different physical processors; not enabling"
- return 1
- fi
-
ebegin "Starting irqbalance"
start-stop-daemon --start --exec /sbin/irqbalance \
--pidfile /var/run/irqbalance.pid
diff --git a/sys-apps/irqbalance/irqbalance-0.55.ebuild b/sys-apps/irqbalance/irqbalance-0.55.ebuild
index d016772737e9..d747881fa98d 100644
--- a/sys-apps/irqbalance/irqbalance-0.55.ebuild
+++ b/sys-apps/irqbalance/irqbalance-0.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55.ebuild,v 1.2 2007/01/09 02:28:22 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-0.55.ebuild,v 1.3 2007/01/21 19:07:25 vapier Exp $
inherit eutils
@@ -25,4 +25,5 @@ src_install() {
into /
dosbin irqbalance || die "dosbin failed"
newinitd "${FILESDIR}"/irqbalance.init irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd irqbalance
}