summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-01-04 23:30:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-01-04 23:30:45 +0000
commitb42cb57cc1fc7b7a914be086d3657235e794cb9d (patch)
tree5b631e7a22b548af6b51e755a43440de1e6cc1d4 /sys-apps/keyutils/keyutils-1.5.5.ebuild
parentUnmask dev-vcs/git mediawiki support on amd64 while other arches are still ke... (diff)
downloadgentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.tar.gz
gentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.tar.bz2
gentoo-2-b42cb57cc1fc7b7a914be086d3657235e794cb9d.zip
Version bump, also fix bug #484452 (AR) and bug #421531 (checking kernel config).
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps/keyutils/keyutils-1.5.5.ebuild')
-rw-r--r--sys-apps/keyutils/keyutils-1.5.5.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/sys-apps/keyutils/keyutils-1.5.5.ebuild b/sys-apps/keyutils/keyutils-1.5.5.ebuild
index ed02fffd0e58..00469b2c3682 100644
--- a/sys-apps/keyutils/keyutils-1.5.5.ebuild
+++ b/sys-apps/keyutils/keyutils-1.5.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.9 2012/07/01 18:21:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.10 2014/01/04 23:30:45 robbat2 Exp $
EAPI="3"
-inherit multilib eutils toolchain-funcs
+inherit multilib eutils toolchain-funcs linux-info
DESCRIPTION="Linux Key Management Utilities"
HOMEPAGE="http://people.redhat.com/dhowells/keyutils/"
@@ -13,10 +13,18 @@ SRC_URI="http://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+pkg_setup() {
+ CONFIG_CHECK="~KEYS"
+ use test && CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ linux-info_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
sed -i \
@@ -43,6 +51,7 @@ src_prepare() {
src_configure() {
tc-export CC
+ tc-export AR
}
src_test() {