summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-18 19:03:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-18 19:03:14 +0000
commit9c22028c8de77bb5c3ea13def5b68d6d8cdfc250 (patch)
tree2ff85e04f081f95a78999e4026cc9108228f92ec /sys-apps/lilo
parentnew samba ebuild (diff)
downloadgentoo-2-9c22028c8de77bb5c3ea13def5b68d6d8cdfc250.tar.gz
gentoo-2-9c22028c8de77bb5c3ea13def5b68d6d8cdfc250.tar.bz2
gentoo-2-9c22028c8de77bb5c3ea13def5b68d6d8cdfc250.zip
Update
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/files/digest-lilo-21.7.31
-rw-r--r--sys-apps/lilo/lilo-21.7.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/lilo/files/digest-lilo-21.7.3 b/sys-apps/lilo/files/digest-lilo-21.7.3
new file mode 100644
index 000000000000..c29e6aaba3f0
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-21.7.3
@@ -0,0 +1 @@
+MD5 3731fe41cac01787e7a58dd041b6e116 lilo-21.7.3.tar.gz
diff --git a/sys-apps/lilo/lilo-21.7.3.ebuild b/sys-apps/lilo/lilo-21.7.3.ebuild
new file mode 100644
index 000000000000..d2f0ab54dab9
--- /dev/null
+++ b/sys-apps/lilo/lilo-21.7.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-21.7.3.ebuild,v 1.1 2001/04/18 19:03:14 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/"${A}
+
+DEPEND="virtual/glibc
+ >=sys-devel/bin86-0.15.4-r1"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-g:${CFLAGS}:" \
+ Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ try pmake
+}
+
+src_install() {
+
+ into /
+ dosbin lilo
+ into /usr
+ dosbin keytab-lilo.pl
+ dodir /boot
+ insinto /boot
+ doins boot-text.b boot-menu.b chain.b os2_d.b
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT QuickInst README*
+}
+
+pkg_preinst() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
+ then
+ einfo "Saving old boot.b..."
+ mv $ROOT/boot/boot.b $ROOT/boot/boot.old;
+ fi
+
+ if [ ! -L $ROOT/boot/chain.b -a -f $ROOT/boot/chain.b ]
+ then
+ einfo "Saving old chain.b..."
+ mv $ROOT/boot/chain.b $ROOT/boot/chain.old;
+ fi
+
+ if [ ! -L $ROOT/boot/os2_d.b -a -f $ROOT/boot/os2_d.b ]
+ then
+ einfo "Saving old os2_d.b..."
+ mv $ROOT/boot/os2_d.b $ROOT/boot/os2_d.old;
+ fi
+}
+
+pkg_postinst() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ einfo "Activating boot-menu..."
+ ln -sf boot-menu.b $ROOT/boot/boot.b;
+
+}
+
+