summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-10-25 18:52:54 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-10-25 18:52:54 +0000
commita7c17d5150f63739c3b2bb2fc654ef1070c33bae (patch)
tree1ea603a3150996775f5023bd3d7b12549087e622 /sys-apps/lm-sensors
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-a7c17d5150f63739c3b2bb2fc654ef1070c33bae.tar.gz
gentoo-2-a7c17d5150f63739c3b2bb2fc654ef1070c33bae.tar.bz2
gentoo-2-a7c17d5150f63739c3b2bb2fc654ef1070c33bae.zip
CC=${CC} >> CC=${tc-getCC}; bug #68382.
Diffstat (limited to 'sys-apps/lm-sensors')
-rw-r--r--sys-apps/lm-sensors/ChangeLog8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild6
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild8
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild8
9 files changed, 38 insertions, 32 deletions
diff --git a/sys-apps/lm-sensors/ChangeLog b/sys-apps/lm-sensors/ChangeLog
index fe31c740bf29..8ada9050483c 100644
--- a/sys-apps/lm-sensors/ChangeLog
+++ b/sys-apps/lm-sensors/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lm-sensors
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.39 2004/10/24 11:41:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.40 2004/10/25 18:52:54 plasmaroo Exp $
+
+ 25 Oct 2004; <plasmaroo@gentoo.org> lm-sensors-2.8.1.ebuild,
+ lm-sensors-2.8.2.ebuild, lm-sensors-2.8.3.ebuild, lm-sensors-2.8.4.ebuild,
+ lm-sensors-2.8.5.ebuild, lm-sensors-2.8.6.ebuild, lm-sensors-2.8.7.ebuild,
+ lm-sensors-2.8.8.ebuild:
+ CC=${CC} >> CC=${tc-getCC}; bug #68382.
*lm-sensors-2.8.8 (24 Oct 2004)
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild
index e6f578e0441e..aa4d44bc553d 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild,v 1.12 2004/09/06 00:33:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.1.ebuild,v 1.13 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -82,7 +82,7 @@ src_compile() {
cd ${S}
emake clean
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules."
}
src_install() {
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild
index 545122293365..abbf38452d0b 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild,v 1.15 2004/07/20 18:22:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.2.ebuild,v 1.16 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -88,9 +88,9 @@ src_compile() {
rm kernel/chips/via686a.d
rm kernel/chips/vt1211.d
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild
index c0a68336c5dd..cef35843984c 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild,v 1.8 2004/07/20 18:22:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.3.ebuild,v 1.9 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -88,9 +88,9 @@ src_compile() {
rm kernel/chips/via686a.d
rm kernel/chips/vt1211.d
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild
index 29e2aa849217..8f1fb1a8c050 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild,v 1.8 2004/07/20 18:22:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.4.ebuild,v 1.9 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -86,9 +86,9 @@ src_compile() {
emake clean
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild
index dd08ea614341..c5a0db28dca8 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild,v 1.8 2004/07/20 18:22:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.5.ebuild,v 1.9 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -86,9 +86,9 @@ src_compile() {
emake clean
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild
index a5cb889b41ec..c07033b2700a 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild,v 1.8 2004/07/20 18:22:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.6.ebuild,v 1.9 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -97,9 +97,9 @@ src_compile() {
emake clean
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
index 6bbf97d67e33..5e88ba105e0b 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild,v 1.6 2004/10/24 11:41:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.7.ebuild,v 1.7 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -101,9 +101,9 @@ src_compile() {
emake clean
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild
index 1e32f609feef..b0c59b2200f3 100644
--- a/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild,v 1.1 2004/10/24 11:41:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.8.ebuild,v 1.2 2004/10/25 18:52:54 plasmaroo Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
MY_P=${PN/-/_}-${PV}
S="${WORKDIR}/${MY_P}"
@@ -101,9 +101,9 @@ src_compile() {
emake clean
if [ ${UserModeOnly} == true ]; then
- emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
else
- emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ emake CC=$(tc-getCC) I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
fi
}