summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-13 19:11:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-13 19:11:07 +0000
commit4ebfd15fc93c25997554e90324326268ea3b374d (patch)
tree00218e0b179701e9b0d81cf5da5e504176cef01c /sys-apps/lsof
parentadded fine grained maintainer setting (diff)
downloadgentoo-2-4ebfd15fc93c25997554e90324326268ea3b374d.tar.gz
gentoo-2-4ebfd15fc93c25997554e90324326268ea3b374d.tar.bz2
gentoo-2-4ebfd15fc93c25997554e90324326268ea3b374d.zip
added the docs again; made updating easier (just cp it); removed the oldest version
Diffstat (limited to 'sys-apps/lsof')
-rw-r--r--sys-apps/lsof/files/digest-lsof-4.60-r11
-rw-r--r--sys-apps/lsof/lsof-4.60-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/lsof/files/digest-lsof-4.60-r1 b/sys-apps/lsof/files/digest-lsof-4.60-r1
new file mode 100644
index 000000000000..018ac5923ed8
--- /dev/null
+++ b/sys-apps/lsof/files/digest-lsof-4.60-r1
@@ -0,0 +1 @@
+MD5 a0f8cebc465ae26ad81e519264272175 lsof_4.60_W.tar.gz 880640
diff --git a/sys-apps/lsof/lsof-4.60-r1.ebuild b/sys-apps/lsof/lsof-4.60-r1.ebuild
new file mode 100644
index 000000000000..54a6c5b34975
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.60-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.60-r1.ebuild,v 1.1 2002/01/13 19:11:07 azarah Exp $
+
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Lists open files for running Unix processes"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}_W.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}_W.tar.gz"
+HOMEPAGE="http://"
+
+DEPEND="virtual/glibc virtual/kernel"
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ tar xf ${MY_P}.tar || die
+ cd ${S}
+}
+
+src_compile() {
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > ${T}/junk
+ ./Configure linux < ${T}/junk
+
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+
+ make all || die
+}
+
+src_install () {
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ doman lsof.8
+ local x
+ for x in 00*
+ do
+ newdoc ${x} ${x/00/}
+ done
+ cd ${D}/usr/share/doc/${PF}
+ mv .README.FIRST.gz README.FIRST.gz
+}
+