summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
commit6958fd94660a6f75a8de8b52b4f994965b22573c (patch)
tree1fc05a3b3717559d2787ef0c8284e2eb26a87775 /sys-apps/lvm-user
parentlots of cleanup. jpeg,zlib,libpng should now extract in the correct dirs (diff)
downloadgentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.gz
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.bz2
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.zip
header, tab fixes
Diffstat (limited to 'sys-apps/lvm-user')
-rw-r--r--sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild b/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild
index 7c95cb65a0eb..1eea88926460 100644
--- a/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild
+++ b/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild,v 1.2 2001/11/24 02:53:00 azarah Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm-user/lvm-user-1.0.1_rc4.ebuild,v 1.3 2002/01/01 22:35:51 azarah Exp $
#our version, but with "eh" formatting
NV=1.0.1-rc4
@@ -9,6 +9,7 @@ S=${WORKDIR}/LVM/${NV}
DESCRIPTION="User-land utilities for LVM (Logical Volume Manager) software"
SRC_URI="ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${NV}.tar.gz"
HOMEPAGE="http://www.mosix.org"
+
DEPEND="virtual/glibc"
KS=/usr/src/linux
@@ -16,13 +17,21 @@ KS=/usr/src/linux
src_compile() {
cd ${S}
[ -f "Makefile" ] && ( make clean || die )
- CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ CFLAGS="${CFLAGS} -I${KS}/include" \
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --with-kernel_dir="${KS}" || die
make || die
}
src_install () {
cd ${S}/tools
- CFLAGS="${CFLAGS} -I${KS}/include" make install -e prefix=${D} mandir=${D}/usr/share/man sbindir=${D}/sbin libdir=${D}/lib || die
+ CFLAGS="${CFLAGS} -I${KS}/include" \
+ make install \
+ -e prefix=${D} \
+ mandir=${D}/usr/share/man \
+ sbindir=${D}/sbin \
+ libdir=${D}/lib || die
#no need for a static library in /lib
dodir /usr/lib
mv ${D}/lib/*.a ${D}/usr/lib