summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-22 00:14:29 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-22 00:14:29 +0000
commit49f4de85a179478a7b7cff7650a072b22a25fe26 (patch)
tree0f1f86da6ff744aca48d48549bfe59c4becba52d /sys-apps/man-db/man-db-2.4.3.ebuild
parentMark 1.2.1 ~ia64 (diff)
downloadgentoo-2-49f4de85a179478a7b7cff7650a072b22a25fe26.tar.gz
gentoo-2-49f4de85a179478a7b7cff7650a072b22a25fe26.tar.bz2
gentoo-2-49f4de85a179478a7b7cff7650a072b22a25fe26.zip
initial import
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps/man-db/man-db-2.4.3.ebuild')
-rw-r--r--sys-apps/man-db/man-db-2.4.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/man-db/man-db-2.4.3.ebuild b/sys-apps/man-db/man-db-2.4.3.ebuild
new file mode 100644
index 000000000000..db58086b21ef
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.4.3.ebuild,v 1.1 2006/02/22 00:14:29 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-libs/db"
+RDEPEND="sys-libs/db
+ !sys-apps/man"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ # the dependency rules are all wrong unless we build
+ # in the src dir ... so we run in parallel in src first
+ # to prevent any race conditions ...
+ mkdir -p {src,libdb}/.depend
+ emake -C src || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,NEWS,ToDo}
+}