summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-05 18:38:55 +0000
committerMike Frysinger <vapier@gentoo.org>2009-04-05 18:38:55 +0000
commitfbe0e87db63d0786946e5c81383d57bee9489907 (patch)
treecec9b85613d0ff20a0d35b2644dd117b324b9d23 /sys-apps/man-db
parentRemove pycups from mask (diff)
downloadgentoo-2-fbe0e87db63d0786946e5c81383d57bee9489907.tar.gz
gentoo-2-fbe0e87db63d0786946e5c81383d57bee9489907.tar.bz2
gentoo-2-fbe0e87db63d0786946e5c81383d57bee9489907.zip
Version bump #264993 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog9
-rw-r--r--sys-apps/man-db/man-db-2.5.5.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index c19571a17c2f..f2b5d36bb379 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.6 2008/11/17 14:51:07 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.7 2009/04/05 18:38:55 vapier Exp $
+
+*man-db-2.5.5 (05 Apr 2009)
+
+ 05 Apr 2009; Mike Frysinger <vapier@gentoo.org> +man-db-2.5.5.ebuild:
+ Version bump #264993 by Arfrever Frehtes Taifersar Arahesis.
*man-db-2.5.3 (17 Nov 2008)
diff --git a/sys-apps/man-db/man-db-2.5.5.ebuild b/sys-apps/man-db/man-db-2.5.5.ebuild
new file mode 100644
index 000000000000..0b25af92bd7c
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.5.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.5.ebuild,v 1.1 2009/04/05 18:38:55 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb gdbm nls"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_compile() {
+ local db="gdbm"
+ use berkdb && ! use gdbm && db="db"
+ econf \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ --with-db=${db} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,HACKING,NEWS,TODO}
+}