summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:52:27 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:52:27 +0000
commite14713d707767fe63c5c8072a857f3ac4c327b35 (patch)
treea9f1caf77611d8541694ea8cbeaea87b62b9ab73 /sys-apps/man/man-1.5i-r3.ebuild
parentupdates for the new snapshot location (diff)
downloadgentoo-2-e14713d707767fe63c5c8072a857f3ac4c327b35.tar.gz
gentoo-2-e14713d707767fe63c5c8072a857f3ac4c327b35.tar.bz2
gentoo-2-e14713d707767fe63c5c8072a857f3ac4c327b35.zip
Removed old digest files.
Changed the ebuild for man to use its own man.conf, which is auto-generated with correct paths for programs. Also it has more standard options, which correctly format some man pages that didn't correctly format before.
Diffstat (limited to 'sys-apps/man/man-1.5i-r3.ebuild')
-rw-r--r--sys-apps/man/man-1.5i-r3.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/man/man-1.5i-r3.ebuild b/sys-apps/man/man-1.5i-r3.ebuild
new file mode 100644
index 000000000000..8e82b7d02127
--- /dev/null
+++ b/sys-apps/man/man-1.5i-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5i-r3.ebuild,v 1.1 2002/04/15 20:52:27 jhhudso Exp $
+
+NV=1.5i2
+S=${WORKDIR}/${PN}-${NV}
+DESCRIPTION="Standard commands to read man pages"
+SRC_URI="http://www.kernel.org/pub/linux/utils/man/man-${NV}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/glibc
+ sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's/confdir=.*$/confdir=\/etc/' \
+ -e 's:/usr/lib/locale:$prefix/usr/lib/locale:g' \
+ -e 's!/bin:/usr/bin:/usr/ucb:/usr/local/bin:$PATH!/bin:/usr/bin:/usr/local/bin:$PATH!' \
+ configure.orig > configure
+ local x
+ for x in / src/ man2html/ msgs/
+ do
+ cd ${S}/${x}
+ cp Makefile.in Makefile.in.orig
+ sed -e '/inst.sh/d' \
+ -e '/^CC =/c\' \
+ -e "CC = gcc" \
+ -e '/^CFLAGS =/c\' \
+ -e "CFLAGS = $CFLAGS" \
+ Makefile.in.orig > Makefile.in
+ done
+}
+
+src_compile() {
+ ./configure +sgid +fhs +lang all || die
+ #for FOOF in src man2html
+ #do
+ # pmake ${FOOF}/Makefile MANCONFIG=/etc/man.conf || die
+ # cd ${S}/${FOOF}
+ # cp Makefile Makefile.orig
+ # sed -e "s/gcc -O/gcc ${CFLAGS}/" Makefile.orig > Makefile
+ # cd ${S}
+ #done
+ make || die
+}
+
+src_install() {
+ dodir /usr/sbin /usr/bin
+ cd ${S}
+ make PREFIX=${D} install || die
+ cd ${S}/msgs
+ ./inst.sh ?? ${D}/usr/share/locale/%L/%N
+ chmod 2555 ${D}/usr/bin/man
+ chown root.man ${D}/usr/bin/man
+ insinto /etc
+ cd ${S}
+ doins src/man.conf
+ dodoc COPYING LSM README* TODO
+}
+
+