summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-30 22:40:25 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-30 22:40:25 +0000
commitf0d2ae8fcca6a1e3c9db1062686b5fdf017823df (patch)
tree6733f72c051b1992e9ec6442499a3fad18450351 /sys-apps/microcode-ctl
parentcleanup (Manifest recommit) (diff)
downloadgentoo-2-f0d2ae8fcca6a1e3c9db1062686b5fdf017823df.tar.gz
gentoo-2-f0d2ae8fcca6a1e3c9db1062686b5fdf017823df.tar.bz2
gentoo-2-f0d2ae8fcca6a1e3c9db1062686b5fdf017823df.zip
Version bump #69360 by Christian Skarby.
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog8
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.101
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.10.ebuild47
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 8cbca60e2431..567fab67b9c3 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.9 2004/10/16 17:00:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.10 2004/10/30 22:40:25 vapier Exp $
+
+*microcode-ctl-1.10 (30 Oct 2004)
+
+ 30 Oct 2004; Mike Frysinger <vapier@gentoo.org>
+ +microcode-ctl-1.10.ebuild:
+ Version bump #69360 by Christian Skarby.
*microcode-ctl-1.09 (16 Oct 2004)
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.10 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.10
new file mode 100644
index 000000000000..24f62bbed327
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.10
@@ -0,0 +1 @@
+MD5 ff8be753e5d5d7275495b7c99bdd55f3 microcode_ctl-1.10.tar.gz 199396
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.10.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.10.ebuild
new file mode 100644
index 000000000000..f19b54549016
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.10.ebuild,v 1.1 2004/10/30 22:40:25 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/os-headers
+ >=sys-apps/portage-2.0.51"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ insinto /etc
+ newins intel-ia32microcode-*.txt microcode.dat
+
+ newinitd ${FILESDIR}/microcode_ctl.rc microcode_ctl
+ newconfd ${FILESDIR}/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}