summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-24 23:37:47 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-24 23:37:47 +0000
commit9f8549089e8e48b9aa9ed0da9c56d50b604780e7 (patch)
treec00104eb08f8d4a06189a06e8b7b42bdf0cb31ed /sys-apps/modutils/modutils-2.4.27.ebuild
parent1.17.2-r1 stable on x86, sparc, and amd64. Added slp USE flag support. (Mani... (diff)
downloadgentoo-2-9f8549089e8e48b9aa9ed0da9c56d50b604780e7.tar.gz
gentoo-2-9f8549089e8e48b9aa9ed0da9c56d50b604780e7.tar.bz2
gentoo-2-9f8549089e8e48b9aa9ed0da9c56d50b604780e7.zip
Version bump, closes bug #60975.
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.27.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.27.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27.ebuild b/sys-apps/modutils/modutils-2.4.27.ebuild
new file mode 100644
index 000000000000..eb633ca77d32
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.27.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27.ebuild,v 1.1 2004/08/24 23:37:47 plasmaroo Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Standard kernel module utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa -amd64 ~ia64 ~ppc64 ~s390"
+IUSE=""
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/modutils"
+
+src_unpack() {
+ unpack ${A}
+
+ EPATCH_OPTS="-d ${S}/util" \
+ epatch ${FILESDIR}/alias.h.diff
+}
+
+src_compile() {
+ local myconf=
+ local mymake=
+
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
+
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local mymake=
+ [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
+ einstall prefix="${D}" ${mymake} || die "make install failed"
+
+ dodoc CREDITS ChangeLog NEWS README TODO
+}