summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-09 20:46:50 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-09 20:46:50 +0000
commit2ac7f99e52dd4d4092ac89a69091813e38d138e3 (patch)
tree57a6ed6f5b91f58fe6ddbfcffff29c86a3e9d2c8 /sys-apps/pciutils
parentRequire pciutils[-zlib] when USE=hwdb #360849 by Samuli Suominen. (diff)
downloadgentoo-2-2ac7f99e52dd4d4092ac89a69091813e38d138e3.tar.gz
gentoo-2-2ac7f99e52dd4d4092ac89a69091813e38d138e3.tar.bz2
gentoo-2-2ac7f99e52dd4d4092ac89a69091813e38d138e3.zip
Add prefix support #388361 by Fabian Groffen.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog5
-rw-r--r--sys-apps/pciutils/pciutils-3.1.8.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 43f7e1e2da92..62622ec0e678 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.183 2011/10/20 00:33:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.184 2011/12/09 20:46:50 vapier Exp $
+
+ 09 Dec 2011; Mike Frysinger <vapier@gentoo.org> pciutils-3.1.8.ebuild:
+ Add prefix support #388361 by Fabian Groffen.
*pciutils-3.1.8 (20 Oct 2011)
diff --git a/sys-apps/pciutils/pciutils-3.1.8.ebuild b/sys-apps/pciutils/pciutils-3.1.8.ebuild
index e877f6862ba8..bb589bcef970 100644
--- a/sys-apps/pciutils/pciutils-3.1.8.ebuild
+++ b/sys-apps/pciutils/pciutils-3.1.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.8.ebuild,v 1.1 2011/10/20 00:33:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.8.ebuild,v 1.2 2011/12/09 20:46:50 vapier Exp $
-EAPI="2"
+EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -34,12 +34,12 @@ pemake() {
CROSS_COMPILE="${CHOST}-" \
CC="$(tc-getCC)" \
DNS="yes" \
- IDSDIR="/usr/share/misc" \
- MANDIR="/usr/share/man" \
- PREFIX="/usr" \
+ IDSDIR='$(SHAREDIR)/misc' \
+ MANDIR='$(SHAREDIR)/man' \
+ PREFIX="${EPREFIX}/usr" \
SHARED="yes" \
STRIP="" \
- ZLIB=$(usex zlib yes no) \
+ ZLIB=$(usex zlib) \
LIBDIR="\${PREFIX}/$(get_libdir)" \
"$@" || die
}