summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-24 20:14:30 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-24 20:14:30 +0000
commit3003cc2a38b2e2d134705e6e52744775fe64c6bf (patch)
tree8dea47a8800f0810fe93bc00bc6ab1d400507716 /sys-apps/pciutils
parentwhen transitioning between USE=zlib and USE=-zlib, make sure to scrub the old... (diff)
downloadgentoo-2-3003cc2a38b2e2d134705e6e52744775fe64c6bf.tar.gz
gentoo-2-3003cc2a38b2e2d134705e6e52744775fe64c6bf.tar.bz2
gentoo-2-3003cc2a38b2e2d134705e6e52744775fe64c6bf.zip
Add workaround for stable where we decompress pci.ids when USE=hal.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog5
-rw-r--r--sys-apps/pciutils/pciutils-2.2.4-r3.ebuild21
2 files changed, 23 insertions, 3 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 149705287876..273092c9b359 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.106 2007/06/22 17:17:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.107 2007/06/24 20:14:30 vapier Exp $
+
+ 24 Jun 2007; Mike Frysinger <vapier@gentoo.org> pciutils-2.2.4-r3.ebuild:
+ Add workaround for stable where we decompress pci.ids when USE=hal.
*pciutils-2.2.6 (22 Jun 2007)
diff --git a/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild b/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild
index 2dbee340d00c..a6cf4e58dc11 100644
--- a/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild,v 1.11 2007/06/15 13:35:56 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r3.ebuild,v 1.12 2007/06/24 20:14:30 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~x86 ~x86-fbsd"
-IUSE="network-cron zlib"
+IUSE="hal network-cron zlib"
DEPEND="zlib? ( sys-libs/zlib )"
@@ -37,7 +37,24 @@ src_install() {
insinto /usr/include/pci
doins lib/{config,header,pci,types}.h || die "headers failed"
+ if use hal ; then
+ # hack around pci-ids because hal sucks
+ sed -i \
+ -e '/^DEST=/s:.gz$::' \
+ -e '/^PCI_COMPRESSED_IDS=/s:=.*:=:' \
+ "${D}"/usr/sbin/update-pciids
+ cd "${D}"/usr/share/misc
+ gunzip pci.ids.gz || die
+ fi
+
use network-cron || return 0
exeinto /etc/cron.monthly
newexe "${FILESDIR}"/pciutils.cron update-pciids || die
}
+
+pkg_postinst() {
+ use hal || return 0
+ # hack around pci-ids because hal sucks
+ cd "${ROOT}"/usr/share/misc
+ rm -f pci.ids.gz{,.old}
+}