summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 22:14:52 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 22:14:52 +0000
commitd0f851ba14758c0217ee9f1f423bd8945100f0a1 (patch)
treea75ac10abb6d23bcb52ffbb47f47d953c8173b56 /sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
parentfix use invocation (Manifest recommit) (diff)
downloadgentoo-2-d0f851ba14758c0217ee9f1f423bd8945100f0a1.tar.gz
gentoo-2-d0f851ba14758c0217ee9f1f423bd8945100f0a1.tar.bz2
gentoo-2-d0f851ba14758c0217ee9f1f423bd8945100f0a1.zip
remove debugging lines and clean up sed usage
Diffstat (limited to 'sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild')
-rw-r--r--sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
index ff88e1a14c39..265b9ba28566 100644
--- a/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
+++ b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild,v 1.5 2004/06/24 22:21:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild,v 1.6 2004/06/28 22:14:52 agriffis Exp $
inherit eutils
@@ -40,8 +40,6 @@ src_unpack() {
sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
chmod ug+x Configure
#man pages will now install into /usr/share/man
-
- einfo `use gtk`
}
src_compile() {
@@ -74,17 +72,10 @@ src_compile() {
# then the gtk version will be installed. If not, but X is in your USE,
# then the xaw version will be installed. Otherwise, no gui will be
# installed.
- sed -e "/^HAS_FORMS/d" config.out > config.out.1
- sed -e "/^HAS_FORMS/d" config.mk > config.mk.1
- sed -i -e "/^HAS_GTK/d" config.out.1
- sed -i -e "/^HAS_GTK/d" config.mk.1
- sed -i -e "/^HAS_XAW/d" config.out.1
- sed -i -e "/^HAS_XAW/d" config.mk.1
- sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.1 > config.out
- sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.1 > config.mk
- rm -f config.out.1
- rm -f config.mk.1
-
+ sed -i -e "/^HAS_FORMS/d" config.out config.mk
+ sed -i -e "/^HAS_GTK/d" config.out config.mk
+ sed -i -e "/^HAS_XAW/d" config.out config.mk
+ sed -i -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out config.mk
# patch version.h so that they won't complain that Card Services is wrong.
if [ -n "`grep -E '^CONFIG_PCMCIA\=y' config.mk`" ]; then