summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-05-23 18:38:50 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-05-23 18:38:50 +0000
commitb2f281502711e7012ddaad0b33d46ed10ad0e3f1 (patch)
treead942e3ed0776a0072e43193531fa8b9d62d2754 /sys-apps/pcsc-lite
parentAdd dev-perl/TermReadKey for git-svn. Fixes bug #179560 (diff)
downloadgentoo-2-b2f281502711e7012ddaad0b33d46ed10ad0e3f1.tar.gz
gentoo-2-b2f281502711e7012ddaad0b33d46ed10ad0e3f1.tar.bz2
gentoo-2-b2f281502711e7012ddaad0b33d46ed10ad0e3f1.zip
Vrsion bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog7
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.23
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.2.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index a11d1be61fac..696ee184f675 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.37 2007/05/17 05:14:02 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.38 2007/05/23 18:38:50 alonbl Exp $
+
+*pcsc-lite-1.4.2 (23 May 2007)
+
+ 23 May 2007; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-lite-1.4.2.ebuild:
+ Vrsion bump
*pcsc-lite-1.4.1 (17 May 2007)
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.2 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.2
new file mode 100644
index 000000000000..8ee57a958619
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.2
@@ -0,0 +1,3 @@
+MD5 285e8161371229242253e8adac96d861 pcsc-lite-1.4.2.tar.gz 624242
+RMD160 9bb5bcf3d376ce9e470e0e0cf64e902100de8ad8 pcsc-lite-1.4.2.tar.gz 624242
+SHA256 a56195b1999e5401df17b62c53944204393ec3e3759699fa00633d8f94bb6570 pcsc-lite-1.4.2.tar.gz 624242
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.2.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.2.ebuild
new file mode 100644
index 000000000000..3b81c67c5f96
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.2.ebuild,v 1.1 2007/05/23 18:38:50 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="1977"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS DRIVERS HELP INSTALL README SECURITY
+ prepalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}