summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-10 19:22:51 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-10 19:22:51 +0000
commit821f1b9f99ca733a4f3f88967e41a6c9636b02b0 (patch)
tree33bbdc37c82ecf696fa2421fead125690a65a0b5 /sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild
parentFix installation of private headers for OSX Framework builds, bug #346221 (diff)
downloadgentoo-2-821f1b9f99ca733a4f3f88967e41a6c9636b02b0.tar.gz
gentoo-2-821f1b9f99ca733a4f3f88967e41a6c9636b02b0.tar.bz2
gentoo-2-821f1b9f99ca733a4f3f88967e41a6c9636b02b0.zip
Revbump for sys-apps/pcsc-slb-rf72-drv. Fixed LDFLAGS respect wrt bug 334775.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild')
-rw-r--r--sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild b/sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..42e56771258a
--- /dev/null
+++ b/sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-slb-rf72-drv/pcsc-slb-rf72-drv-1.1.0-r2.ebuild,v 1.1 2010/12/10 19:22:51 c1pher Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="slb_rf72"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Schlumberger Reflex 72 Serial Smartcard Reader"
+HOMEPAGE="http://www.linuxnet.com/sourcedrivers.html"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT="0"
+SRC_URI="http://www.linuxnet.com/drivers/readers/files/slb_rf72-drv-1.1.0.tar.gz"
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/openct"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build-new.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" || die
+}
+
+src_install () {
+ local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
+ local conf="/etc/reader.conf.d/${PN}.conf"
+
+ dodoc ERRATA README || die
+
+ dodir "${pcscdir}/serial" || die
+ insinto "${pcscdir}/serial"
+ insopts -m755
+ doins libslb_rf72.so || die
+
+ dodir "$(dirname "${conf}")" || die
+ insinto "$(dirname "${conf}")"
+ newins "${FILESDIR}/reader.conf" "$(basename "${conf}")" || die
+ sed -i "s#%PCSC_DRIVERS_DIR%#${pcscdir}#g" "${D}/${conf}" || die
+
+ einfo "NOTICE:"
+ einfo "1. modify ${conf}"
+ einfo "2. run update-reader.conf, yes this is a command..."
+ einfo "3. restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]; then
+ rm "${conf}"
+ update-reader.conf
+ einfo "NOTICE:"
+ einfo "You need to restart pcscd"
+ fi
+}