summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-08 11:50:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-08 11:50:28 +0000
commitdac5497f75f118c01d57a92c34ed16d5c58470a4 (patch)
tree0d6cde3a39c95a54b8a8d38e8dd3df566e98bcd2 /sys-apps/procps/procps-3.1.13-r1.ebuild
parentkill and uptime belong to procps, so this version bump should assure that (diff)
downloadgentoo-2-dac5497f75f118c01d57a92c34ed16d5c58470a4.tar.gz
gentoo-2-dac5497f75f118c01d57a92c34ed16d5c58470a4.tar.bz2
gentoo-2-dac5497f75f118c01d57a92c34ed16d5c58470a4.zip
kill and uptime belong to procps, so this version bump should assure that
Diffstat (limited to 'sys-apps/procps/procps-3.1.13-r1.ebuild')
-rw-r--r--sys-apps/procps/procps-3.1.13-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/procps/procps-3.1.13-r1.ebuild b/sys-apps/procps/procps-3.1.13-r1.ebuild
new file mode 100644
index 000000000000..35ee33200554
--- /dev/null
+++ b/sys-apps/procps/procps-3.1.13-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.1.13-r1.ebuild,v 1.1 2003/12/08 11:50:27 seemant Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard informational utilities and process-handling tools -ps top tload snice vmstat free w watch uptime pmap skill pkill kill pgrep sysctl"
+SRC_URI="http://${PN}.sf.net/${P}.tar.gz"
+HOMEPAGE="http://procps.sourceforge.net/"
+
+inherit flag-o-matic
+
+replace-flags "-O3" "-O2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 amd64 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ia64"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Use the CFLAGS from /etc/make.conf.
+ for file in `find . -iname "Makefile"`;do
+ sed -i "s:-O2:${CFLAGS}:" ${file}
+ done
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR="${D}"|| die
+
+ dodoc BUGS COPYING COPYING.LIB NEWS TODO
+ docinto proc
+ dodoc proc/COPYING
+ docinto ps
+ dodoc ps/COPYING ps/HACKING
+}
+
+pkg_postinst() {
+ einfo "NOTE: By default \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use the '-m' flag"
+ einfo "in ps or the 'H' key in top to show them"
+}