summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-10 21:40:36 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-10 21:40:36 +0000
commit973093fb08dd4297bc407f63622532b33466785a (patch)
tree4a5d55108f6810029dafbfe013c14cd79429faef /sys-apps/pv
parentMoving net-misc/ptunnel to net-proxy/pingtunnel (diff)
downloadgentoo-2-973093fb08dd4297bc407f63622532b33466785a.tar.gz
gentoo-2-973093fb08dd4297bc407f63622532b33466785a.tar.bz2
gentoo-2-973093fb08dd4297bc407f63622532b33466785a.zip
If sys-apps/usleep is not installed, use sleep instead.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/ChangeLog5
-rw-r--r--sys-apps/pv/pv-1.4.0.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index 781301316770..8c70423b42fe 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.45 2012/12/10 12:04:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.46 2012/12/10 21:40:36 jer Exp $
+
+ 10 Dec 2012; Jeroen Roovers <jer@gentoo.org> pv-1.4.0.ebuild:
+ If sys-apps/usleep is not installed, use sleep instead.
*pv-1.4.0 (10 Dec 2012)
diff --git a/sys-apps/pv/pv-1.4.0.ebuild b/sys-apps/pv/pv-1.4.0.ebuild
index c2e2015ad5a5..42b94a3e9675 100644
--- a/sys-apps/pv/pv-1.4.0.ebuild
+++ b/sys-apps/pv/pv-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.4.0.ebuild,v 1.1 2012/12/10 12:04:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.4.0.ebuild,v 1.2 2012/12/10 21:40:36 jer Exp $
EAPI="4"
@@ -32,6 +32,13 @@ src_configure() {
econf $(use_enable nls)
}
+src_test() {
+ if ! has_version sys-apps/usleep; then
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ fi
+ default
+}
+
src_compile() {
emake LD="$(tc-getLD)"
}