summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-01-05 18:15:22 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-01-05 18:15:22 +0000
commit18479ec2772655f046cdac04051a64a3fb4745f8 (patch)
tree3bf239608f18d655dc83a30fbef58e02698521e0 /sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild
parentIcon is a PNG not a XPM. (Manifest recommit) (diff)
downloadgentoo-2-18479ec2772655f046cdac04051a64a3fb4745f8.tar.gz
gentoo-2-18479ec2772655f046cdac04051a64a3fb4745f8.tar.bz2
gentoo-2-18479ec2772655f046cdac04051a64a3fb4745f8.zip
Updated ebuild to support linux-mod eclass.
Diffstat (limited to 'sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild')
-rw-r--r--sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild b/sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..dba9e16b1141
--- /dev/null
+++ b/sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/realtime-lsm/realtime-lsm-0.8.5-r1.ebuild,v 1.1 2005/01/05 18:15:22 fafhrd Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Enable realtime capabilties via a security module."
+
+HOMEPAGE="http://www.joq.us/"
+#HOMEPAGE="http://www.sourceforge.net/projects/realtime-lsm/"
+SRC_URI="http://www.joq.us/realtime/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE=""
+DEPEND="${DEPEND}"
+RDEPEND="${RDEPEND}"
+
+MODULE_NAMES="realtime(extra:)"
+BUILD_PARAMS="KSRC=${ROOT}${KV_DIR} TOUT=${TMP}/tmp-gas-check"
+BUILD_TARGETS="all"
+MODULESD_REALTIME_DOCS="AUTHORS ChangeLog README"
+
+src_unpack() {
+ if ! linux_chkconfig_present SECURITY
+ then
+ eerror ""
+ eerror "${PN} requires you to compile in the 'different security models option."
+ eerror "In your .config: CONFIG_SECURITY=y"
+ eerror "Through 'make menuconfig': Security options-> [*] Enable different security models"
+ eerror ""
+ die "Security support not detected."
+ fi
+
+ if ! linux_chkconfig_module SECURITY_CAPABILITIES
+ then
+ eerror ""
+ eerror "${PN} requires that 'Default Linux Capabilities' be compiled as a module."
+ eerror "In your .config: CONFIG_SECURITY_CAPABILITIES=m"
+ eerror "Through 'make menuconfig': Security options-> <M> Default Linux Capabilties"
+ eerror ""
+ die "Default Linux capabilities (security) not detected."
+ fi
+
+ if ! kernel_is 2 6
+ then
+ die "A Linux kernel of version 2.6 is required."
+ fi
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/kmisc.patch-0.8.2_pre20041022
+ convert_to_m Makefile
+}
+