summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-26 00:39:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-26 00:39:57 +0000
commit2c9c37e04a5c3721a0d1c8b5475b2d411c365a34 (patch)
tree9c4842962dd8f9104603547f3ce620c57ecb86fc /sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild
parentMake it work for python 2.6, thanks Dustin Polke, closing bug #278028 (diff)
downloadgentoo-2-2c9c37e04a5c3721a0d1c8b5475b2d411c365a34.tar.gz
gentoo-2-2c9c37e04a5c3721a0d1c8b5475b2d411c365a34.tar.bz2
gentoo-2-2c9c37e04a5c3721a0d1c8b5475b2d411c365a34.zip
Bug #278909: Upstream re-released v1.27, 9 months later, with a LOT of updates. Adding the date into the version number so that we can track which release was actually being used. Copies of each tarball uploaded the mirrors. Also use relative symlinks instead of absolute ones for the libsgutils2/libsgutils compat fix.
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild
new file mode 100644
index 000000000000..ca4026b60a73
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.27.20080726-r1.ebuild,v 1.1 2009/07/26 00:39:57 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+#SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+S="${WORKDIR}/${P/.200*}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README.doc examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/{scsi,sas}* || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}