summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-10 01:19:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-10 01:19:01 +0000
commit00d4003da62e391adb75e7c4a7ce717f8a996a59 (patch)
tree0a3733952aacee73d48bdbf4a3e497d2619bff7d /sys-apps/smartmontools
parentold (Manifest recommit) (diff)
downloadgentoo-2-00d4003da62e391adb75e7c4a7ce717f8a996a59.tar.gz
gentoo-2-00d4003da62e391adb75e7c4a7ce717f8a996a59.tar.bz2
gentoo-2-00d4003da62e391adb75e7c4a7ce717f8a996a59.zip
ver bump #62717
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/files/digest-smartmontools-5.331
-rw-r--r--sys-apps/smartmontools/files/smartd.confd6
-rw-r--r--sys-apps/smartmontools/files/smartd.rc26
-rw-r--r--sys-apps/smartmontools/smartmontools-5.33.ebuild24
5 files changed, 59 insertions, 6 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index e894bb4b557e..a52846282232 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.34 2004/06/24 22:26:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.35 2004/10/10 01:19:01 vapier Exp $
+
+*smartmontools-5.33 (09 Oct 2004)
+
+ 09 Oct 2004; Mike Frysinger <vapier@gentoo.org> +files/smartd.confd,
+ files/smartd.rc, +smartmontools-5.33.ebuild:
+ Version bump #62717 by Ziga Boehm.
24 May 2004; Bryan Østergaard <kloeri@gentoo.org> smartmontools-5.30.ebuild:
Keyworded ~alpha, requested in bug #51550.
diff --git a/sys-apps/smartmontools/files/digest-smartmontools-5.33 b/sys-apps/smartmontools/files/digest-smartmontools-5.33
new file mode 100644
index 000000000000..986515d17c4c
--- /dev/null
+++ b/sys-apps/smartmontools/files/digest-smartmontools-5.33
@@ -0,0 +1 @@
+MD5 53f6861a916169a88a9edb1848e27dd0 smartmontools-5.33.tar.gz 509826
diff --git a/sys-apps/smartmontools/files/smartd.confd b/sys-apps/smartmontools/files/smartd.confd
new file mode 100644
index 000000000000..762e3847c790
--- /dev/null
+++ b/sys-apps/smartmontools/files/smartd.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.confd,v 1.1 2004/10/10 01:19:01 vapier Exp $
+
+# Insert any other options needed
+SMARTD_OPTS=""
diff --git a/sys-apps/smartmontools/files/smartd.rc b/sys-apps/smartmontools/files/smartd.rc
index 3a1034918054..c4a5c3c79381 100644
--- a/sys-apps/smartmontools/files/smartd.rc
+++ b/sys-apps/smartmontools/files/smartd.rc
@@ -1,20 +1,36 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.3 2004/07/15 00:51:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/files/smartd.rc,v 1.4 2004/10/10 01:19:01 vapier Exp $
-depend() {
- need localmount
+opts="${opts} reload"
+
+checkconfig() {
+ if [ ! -f "/etc/smartd.conf" ] ; then
+ eerror "You should setup your /etc/smartd.conf file!"
+ eerror "See sample conf: /etc/smartd.conf.example"
+ return 1
+ fi
+ return 0
}
start() {
+ checkconfig || return 1
+
ebegin "Starting S.M.A.R.T. monitoring daemon"
- start-stop-daemon --start --exec /usr/sbin/smartd
+ start-stop-daemon --start --exec /usr/sbin/smartd \
+ -- -p /var/run/smartd.pid ${SMARTD_OPTS}
eend $?
}
stop() {
ebegin "Stopping S.M.A.R.T. monitoring daemon"
- start-stop-daemon --stop --exec /usr/sbin/smartd
+ start-stop-daemon --stop --pid /var/run/smartd.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading configuration"
+ killall -HUP smartd &>/dev/null
eend $?
}
diff --git a/sys-apps/smartmontools/smartmontools-5.33.ebuild b/sys-apps/smartmontools/smartmontools-5.33.ebuild
new file mode 100644
index 000000000000..55a777f575bb
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.33.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.33.ebuild,v 1.1 2004/10/10 01:19:01 vapier Exp $
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_install() {
+ dosbin smart{ctl,d} || die "dosbin"
+ doman *.[58]
+ dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
+
+ insinto /etc
+ doins smartd.conf
+
+ exeinto /etc/init.d; newexe ${FILESDIR}/smartd.rc smartd
+ insinto /etc/conf.d; newins ${FILESDIR}/smartd.confd smartd
+}