summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-24 02:48:44 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-24 02:48:44 +0000
commit6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff (patch)
tree4d86b176149de859b4dd3c80b68daf924abc3d70 /sys-apps/stat/stat-2.5.ebuild
parentoops (diff)
downloadgentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.tar.gz
gentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.tar.bz2
gentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.zip
added selinux support
Diffstat (limited to 'sys-apps/stat/stat-2.5.ebuild')
-rw-r--r--sys-apps/stat/stat-2.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/stat/stat-2.5.ebuild b/sys-apps/stat/stat-2.5.ebuild
index 37e7d6b65620..9fbb2d0b964c 100644
--- a/sys-apps/stat/stat-2.5.ebuild
+++ b/sys-apps/stat/stat-2.5.ebuild
@@ -1,21 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/stat-2.5.ebuild,v 1.7 2003/02/13 16:15:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/stat-2.5.ebuild,v 1.8 2003/03/24 02:48:44 method Exp $
+IUSE="selinux"
S=${WORKDIR}/${P}
DESCRIPTION="A command-line stat() wrapper."
-SRC_URI="ftp://metalab.unc.edu/pub/linux/utils/file/${P}.tar.gz"
+SRC_URI="ftp://metalab.unc.edu/pub/linux/utils/file/${P}.tar.gz
+ selinux? mirror://gentoo/${P}-selinux.patch.bz2"
HOMEPAGE="http://www.gnu.org/directory/stat.html"
KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc
+ selinux? ( sys-apps/selinux-small )"
+inherit eutils
src_unpack() {
unpack ${A}
cd ${S}
+
+ use selinux && epatch ${DISTDIR}/${P}-selinux.patch.bz2
+
cp Makefile Makefile.orig
sed -e "s:-O2 -g:${CFLAGS}:" Makefile.orig > Makefile
+
}
src_compile() {