summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-09-04 19:10:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-09-04 19:10:02 +0000
commitc54d87a3c4b4b32c61d50f999b749c15311f7220 (patch)
tree8689a35eb9d1098b9bc66e44773257cc86ab95bd /sys-apps/syslog-notify/syslog-notify-0.1.ebuild
parentEbuild from rion-overlay with minor changes. Thanks to Andreis Vinogradovs (diff)
downloadgentoo-2-c54d87a3c4b4b32c61d50f999b749c15311f7220.tar.gz
gentoo-2-c54d87a3c4b4b32c61d50f999b749c15311f7220.tar.bz2
gentoo-2-c54d87a3c4b4b32c61d50f999b749c15311f7220.zip
Move mkfifo to pkg_postinst. Bug #307649
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/syslog-notify/syslog-notify-0.1.ebuild')
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-apps/syslog-notify/syslog-notify-0.1.ebuild b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
index adfe88008f31..72e6bc4eb24d 100644
--- a/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
+++ b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/syslog-notify-0.1.ebuild,v 1.6 2012/07/12 19:12:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/syslog-notify-0.1.ebuild,v 1.7 2012/09/04 19:10:02 hwoarang Exp $
EAPI=2
inherit eutils
@@ -24,14 +24,15 @@ src_prepare() {
src_install() {
dosbin src/syslog-notify || die
- ebegin "Creating /var/spool/syslog-notify FIFO"
dodir /var/spool/ || die
- mkfifo "${D}"var/spool/syslog-notify || die
- eend $?
dodoc AUTHORS INSTALL README || die
}
pkg_postinst() {
+ mkfifo "${D}"var/spool/syslog-notify || die
+}
+
+pkg_postinst() {
elog "Add the following options on your"
elog "/etc/syslog-ng/syslog-ng.conf file:"
elog " # destination notify { pipe("/var/spool/syslog-notify"); };"