summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-03-31 11:52:03 +0000
committerMichał Górny <mgorny@gentoo.org>2012-03-31 11:52:03 +0000
commite98ac38cc3d8926b46a0c3a4a071089bbb8b3752 (patch)
tree52bcf0814fef845115c6f8e6dfe16247f6662a33 /sys-apps/systemd-ui
parentSome eclass fuck up S declaration in eapi4 :/ (diff)
downloadgentoo-2-e98ac38cc3d8926b46a0c3a4a071089bbb8b3752.tar.gz
gentoo-2-e98ac38cc3d8926b46a0c3a4a071089bbb8b3752.tar.bz2
gentoo-2-e98ac38cc3d8926b46a0c3a4a071089bbb8b3752.zip
Introduce a separate ebuild for the first release of systemd-ui.
(Portage version: 2.2.0_alpha96_p5/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/systemd-ui')
-rw-r--r--sys-apps/systemd-ui/ChangeLog10
-rw-r--r--sys-apps/systemd-ui/Manifest4
-rw-r--r--sys-apps/systemd-ui/metadata.xml8
-rw-r--r--sys-apps/systemd-ui/systemd-ui-1.ebuild47
4 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/systemd-ui/ChangeLog b/sys-apps/systemd-ui/ChangeLog
new file mode 100644
index 000000000000..2344f8946aed
--- /dev/null
+++ b/sys-apps/systemd-ui/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/systemd-ui
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.1 2012/03/31 11:52:03 mgorny Exp $
+
+*systemd-ui-1 (31 Mar 2012)
+
+ 31 Mar 2012; Michał Górny <mgorny@gentoo.org> +systemd-ui-1.ebuild,
+ +metadata.xml:
+ Introduce a separate ebuild for the first release of systemd-ui.
+
diff --git a/sys-apps/systemd-ui/Manifest b/sys-apps/systemd-ui/Manifest
new file mode 100644
index 000000000000..ecd34ae90ab7
--- /dev/null
+++ b/sys-apps/systemd-ui/Manifest
@@ -0,0 +1,4 @@
+DIST systemd-ui-1.tar.xz 150000 RMD160 e1a42565f5388cca963b982dc82c30bfad39de65 SHA1 94484cf7998ef407f1dad42f920a9622be41c6cc SHA256 7f8c27ce9a1e51ae409f5320406a8ed83fdb9088fc313a7cfcc93673345f8dab
+EBUILD systemd-ui-1.ebuild 969 RMD160 187aa37c6be33821b9211d03d3bbc09c91aa62d8 SHA1 5ef04a189e6695dfbf0559ff415b05819522fbe1 SHA256 5e03f35680121f0880c002b7a03c2e784d4d46ae3c5881408b92b5820b625079
+MISC ChangeLog 306 RMD160 f1a8a4e3ca4e01168265e006b76c3199f4e849c0 SHA1 b6949b2f505877866048de210755d5f54608ee2c SHA256 f3a7e8f61031399eb9a316b4c827ed967812e2e1de85259c37579d0b28c7c1f4
+MISC metadata.xml 239 RMD160 48fff3a59a14a4674f4923e61acccea48406b2c9 SHA1 f498cfad0908520548dc5ec84a120cb0b5504bea SHA256 1731c6552b4584e3ca0d760cb9504233311f18bdd2804cebfc06feb2f60b042b
diff --git a/sys-apps/systemd-ui/metadata.xml b/sys-apps/systemd-ui/metadata.xml
new file mode 100644
index 000000000000..fe305d209585
--- /dev/null
+++ b/sys-apps/systemd-ui/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>systemd@gentoo.org</email>
+ <name>Gentoo systemd team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/systemd-ui/systemd-ui-1.ebuild b/sys-apps/systemd-ui/systemd-ui-1.ebuild
new file mode 100644
index 000000000000..0ede5f9a5024
--- /dev/null
+++ b/sys-apps/systemd-ui/systemd-ui-1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-1.ebuild,v 1.1 2012/03/31 11:52:03 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VALASLOT="0.14"
+
+RDEPEND="!sys-apps/systemd[gtk]
+ >=dev-libs/glib-2.26
+ dev-libs/libgee:0
+ sys-apps/dbus
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-lang/vala:${VALASLOT}"
+
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export VALAC="$(type -p valac-${VALASLOT})"
+ autotools-utils_src_configure
+}