summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-10-19 23:17:09 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-10-19 23:17:09 +0000
commitf25d791cd81957098f44996b93566445acf951d3 (patch)
treee8bfcdd083491a754e57cb1151a3f3e4273edacc /sys-apps/tic98/files/tic98-1.01-gentoo.diff
parentcleanup; removed removal of users (diff)
downloadgentoo-2-f25d791cd81957098f44996b93566445acf951d3.tar.gz
gentoo-2-f25d791cd81957098f44996b93566445acf951d3.tar.bz2
gentoo-2-f25d791cd81957098f44996b93566445acf951d3.zip
digest, patches, etc in filesdir
Diffstat (limited to 'sys-apps/tic98/files/tic98-1.01-gentoo.diff')
-rw-r--r--sys-apps/tic98/files/tic98-1.01-gentoo.diff82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/tic98/files/tic98-1.01-gentoo.diff b/sys-apps/tic98/files/tic98-1.01-gentoo.diff
new file mode 100644
index 000000000000..21ab2f3a68cf
--- /dev/null
+++ b/sys-apps/tic98/files/tic98-1.01-gentoo.diff
@@ -0,0 +1,82 @@
+diff -Nru tic98/Makefile tic98.gentoo/Makefile
+--- tic98/Makefile 1999-06-22 05:00:58.000000000 -0400
++++ tic98.gentoo/Makefile 2002-10-19 18:20:55.000000000 -0400
+@@ -1,4 +1,4 @@
+-BIN=/home/singlis/linux/bin
++BIN=/usr/bin
+ IMAGES=/home/ml/singlis
+ LIBTIC=
+ LIBS= -lm #-L/home/singlis/linux/lib -lccmalloc -ldl
+@@ -180,4 +180,4 @@
+ boundary.o getopt.o windowing.o
+ $(CC) -o $@ $^ $(LIBS)
+
+-
+\ No newline at end of file
++
+diff -Nru tic98/arithcode.c tic98.gentoo/arithcode.c
+--- tic98/arithcode.c 1999-06-21 21:48:40.000000000 -0400
++++ tic98.gentoo/arithcode.c 2002-10-19 18:19:20.000000000 -0400
+@@ -610,7 +610,7 @@
+ bits_to_go = 0;
+ }
+
+-#ifdef 0
++#ifdef none
+ void
+ arith_encode( unsigned int lbnd, unsigned int hbnd, unsigned int totl )
+ /* Arithmetically encode the range. */
+@@ -645,7 +645,7 @@
+ }
+
+
+-#ifdef 0
++#ifdef none
+ void arith_decode( unsigned int lbnd, unsigned int hbnd, unsigned int totl )
+ /* Arithmetically decode the range. */
+ {
+@@ -726,7 +726,7 @@
+
+
+
+-#ifdef 0
++#ifdef none
+
+ void
+ EncodeGammaSigned (int snum, int *pos, int *neg)
+diff -Nru tic98/b_gamma.c tic98.gentoo/b_gamma.c
+--- tic98/b_gamma.c 1999-06-21 21:48:41.000000000 -0400
++++ tic98.gentoo/b_gamma.c 2002-10-19 18:18:43.000000000 -0400
+@@ -187,7 +187,7 @@
+ }
+ }
+
+-#ifdef 0
++#ifdef none
+ void
+ b_gamma_encode_64(unsigned long num)
+ {
+diff -Nru tic98/docstrum.c tic98.gentoo/docstrum.c
+--- tic98/docstrum.c 1999-07-01 15:58:37.000000000 -0400
++++ tic98.gentoo/docstrum.c 2002-10-19 18:19:39.000000000 -0400
+@@ -672,7 +672,7 @@
+ calc_docstrum_spacing(list,neighs,0,&within,&between);
+
+ prune_neighbours_distance(neighs,len, 3*between);
+-#ifdef 0
++#ifdef none
+ prune_neighbours_angle_distance(neighs,len, 0,30, 6*within/*MIN(6*within,sqrt(2.0)*between)*/);
+ #endif
+
+diff -Nru tic98/ppmd_model.c tic98.gentoo/ppmd_model.c
+--- tic98/ppmd_model.c 1999-06-21 21:48:42.000000000 -0400
++++ tic98.gentoo/ppmd_model.c 2002-10-19 18:20:33.000000000 -0400
+@@ -496,7 +496,7 @@
+ arithmetic_encode( lbnd, hbnd, totl );
+ }
+
+-#ifdef 0
++#ifdef none
+ unsigned int
+ arith_decode_target (unsigned int totl)
+ /* Arithmetically decodes the target. */