summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzlg <zlg@gentoo.org>2015-06-20 05:31:55 +0000
committerzlg <zlg@gentoo.org>2015-06-20 05:31:55 +0000
commite37fa3ef63d6237ab11a1945a8c1ed6044889fd5 (patch)
treef7417c92eb2a75a5e8ca0d6d854e68b1631d2a62 /sys-apps/udevil
parentStable for PPC64 (bug #536012). (diff)
downloadgentoo-2-e37fa3ef63d6237ab11a1945a8c1ed6044889fd5.tar.gz
gentoo-2-e37fa3ef63d6237ab11a1945a8c1ed6044889fd5.tar.bz2
gentoo-2-e37fa3ef63d6237ab11a1945a8c1ed6044889fd5.zip
Revbump wrt bug #552072. Thanks Helmut Jarausch.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 5039E170)
Diffstat (limited to 'sys-apps/udevil')
-rw-r--r--sys-apps/udevil/ChangeLog8
-rw-r--r--sys-apps/udevil/files/udevil-0.4.4-stat.patch11
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r1.ebuild73
3 files changed, 91 insertions, 1 deletions
diff --git a/sys-apps/udevil/ChangeLog b/sys-apps/udevil/ChangeLog
index 168b78596d7d..075f80f0ed02 100644
--- a/sys-apps/udevil/ChangeLog
+++ b/sys-apps/udevil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/udevil
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/ChangeLog,v 1.38 2015/06/14 06:16:20 zlg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/ChangeLog,v 1.39 2015/06/20 05:31:55 zlg Exp $
+
+*udevil-0.4.4-r1 (20 Jun 2015)
+
+ 20 Jun 2015; Daniel Campbell <zlg@gentoo.org> +udevil-0.4.4-r1.ebuild,
+ +files/udevil-0.4.4-stat.patch:
+ Revbump wrt bug #552072
*udevil-0.4.4 (14 Jun 2015)
diff --git a/sys-apps/udevil/files/udevil-0.4.4-stat.patch b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
new file mode 100644
index 000000000000..22e41d467821
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
@@ -0,0 +1,11 @@
+Fixes bug #552072. Thanks Helmut Jarausch.
+--- src/device-info.h
++++ src/device-info.h
+@@ -14,6 +14,7 @@
+ #include <libudev.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ // intltool
+ #include <glib/gi18n.h>
diff --git a/sys-apps/udevil/udevil-0.4.4-r1.ebuild b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..a6f8f1336483
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/udevil-0.4.4-r1.ebuild,v 1.1 2015/06/20 05:31:55 zlg Exp $
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0:*
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # This works for 0.4.4 too, no sense copying the patch
+ epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ epatch "${FILESDIR}"/${P}-stat.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}