summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 16:52:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 16:52:36 +0000
commitda6f4730800db156ee7d7fc9016de6fb9e900b5b (patch)
tree585be89051d4d92c75b9a4d899f59a5e6c8f83c0 /sys-apps/usbutils
parentUse PYTHON_REQUIRED_USE to abort early if required. (diff)
downloadgentoo-2-da6f4730800db156ee7d7fc9016de6fb9e900b5b.tar.gz
gentoo-2-da6f4730800db156ee7d7fc9016de6fb9e900b5b.tar.bz2
gentoo-2-da6f4730800db156ee7d7fc9016de6fb9e900b5b.zip
old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/ChangeLog7
-rwxr-xr-xsys-apps/usbutils/files/usbmodules.sh55
-rwxr-xr-xsys-apps/usbutils/files/usbutils.cron2
-rw-r--r--sys-apps/usbutils/usbutils-004.ebuild56
-rw-r--r--sys-apps/usbutils/usbutils-006-r1.ebuild54
-rw-r--r--sys-apps/usbutils/usbutils-006.ebuild66
6 files changed, 6 insertions, 234 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index 7ff74189b923..6bf39bd3fda8 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.179 2014/04/07 16:50:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.180 2014/04/07 16:52:35 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> -files/usbmodules.sh,
+ -files/usbutils.cron, -usbutils-004.ebuild, -usbutils-006-r1.ebuild,
+ -usbutils-006.ebuild:
+ old
07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> usbutils-007.ebuild:
Use PYTHON_REQUIRED_USE to abort early if required.
diff --git a/sys-apps/usbutils/files/usbmodules.sh b/sys-apps/usbutils/files/usbmodules.sh
deleted file mode 100755
index dfd89b7f307b..000000000000
--- a/sys-apps/usbutils/files/usbmodules.sh
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-
-usage() {
- cat <<-EOF
- List relevant kernel modules for USB devices currently plugged in. The
- module list is taken from the modules installed in /lib/modules/<ver>/.
-
- Usage: usbmodules [options] [kernel version]
-
- Options:
- -m, --map <map> Specify usbmap (default: /lib/modules/<ver>/modules.usbmap)
- -h, --help This help screen
- EOF
- if [ -n "$*" ] ; then
- echo
- echo "Error: $*" 1>&2
- exit 1
- else
- exit 0
- fi
-}
-
-map=""
-
-while [ -n "$1" ] ; do
- case $1 in
- -m|--map) map=$2; shift;;
- -h|--help) usage;;
- --) break;;
- -*) usage "unknown option '$1'";;
- *) break;;
- esac
- shift
-done
-
-ver=${1:-$(uname -r)}
-map=${map:-/lib/modules/${ver}/modules.usbmap}
-
-for dev in $(lsusb | awk '{print $6}') ; do
- [ "${dev}" = "0000:0000" ] && continue
-
- IFS=:
- set -- ${dev}
- vendor=$1
- product=$2
- unset IFS
-
- awk \
- -v vendor="0x${vendor}" \
- -v product="0x${product}" \
- 'vendor == $3 && product == $4 {print $1}' \
- ${map}
-done
-
-exit 0
diff --git a/sys-apps/usbutils/files/usbutils.cron b/sys-apps/usbutils/files/usbutils.cron
deleted file mode 100755
index 1018546d18fe..000000000000
--- a/sys-apps/usbutils/files/usbutils.cron
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/sbin/update-usbids -q
diff --git a/sys-apps/usbutils/usbutils-004.ebuild b/sys-apps/usbutils/usbutils-004.ebuild
deleted file mode 100644
index e4b0b83ed396..000000000000
--- a/sys-apps/usbutils/usbutils-004.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-004.ebuild,v 1.8 2012/05/04 09:17:26 jdhore Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit python
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="http://linux-usb.sourceforge.net/"
-SRC_URI="mirror://kernel/linux/utils/usb/usbutils/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="network-cron python zlib"
-
-RDEPEND="virtual/libusb:1
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use python; then
- python_convert_shebangs 2 lsusb.py
- sed -i -e '/^usbids/s:/usr/share:/usr/share/misc:' lsusb.py || die
- fi
-}
-
-src_configure() {
- econf \
- --datarootdir=/usr/share \
- --datadir=/usr/share/misc \
- $(use_enable zlib)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- use python || rm -f "${D}"/usr/bin/lsusb.py
- mv "${D}"/usr/sbin/update-usbids{.sh,} || die
- newbin "${FILESDIR}"/usbmodules.sh usbmodules || die
- dodoc AUTHORS ChangeLog NEWS README
-
- use network-cron || return 0
- exeinto /etc/cron.monthly
- newexe "${FILESDIR}"/usbutils.cron update-usbids || die
-}
diff --git a/sys-apps/usbutils/usbutils-006-r1.ebuild b/sys-apps/usbutils/usbutils-006-r1.ebuild
deleted file mode 100644
index e24a60ca2a40..000000000000
--- a/sys-apps/usbutils/usbutils-006-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006-r1.ebuild,v 1.14 2013/09/05 09:55:09 vapier Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-single-r1
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="http://linux-usb.sourceforge.net/"
-SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="python zlib"
-
-RDEPEND="virtual/libusb:1=
- zlib? ( sys-libs/zlib:= )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- sys-apps/hwids
- python? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-stdint.patch
-
- sed -i -e '/^usbids/s:/usr/share:/usr/share/misc:' lsusb.py || die
-
- use python && python_fix_shebang lsusb.py
-}
-
-src_configure() {
- econf \
- --datarootdir="${EPREFIX}/usr/share" \
- --datadir="${EPREFIX}/usr/share/misc" \
- --disable-usbids \
- $(use_enable zlib)
-}
-
-src_install() {
- default
- newdoc usbhid-dump/NEWS NEWS.usbhid-dump
-
- use python || rm -f "${ED}"/usr/bin/lsusb.py
-}
diff --git a/sys-apps/usbutils/usbutils-006.ebuild b/sys-apps/usbutils/usbutils-006.ebuild
deleted file mode 100644
index 14dbcfc5d96e..000000000000
--- a/sys-apps/usbutils/usbutils-006.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006.ebuild,v 1.12 2013/04/19 06:03:22 ssuominen Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit eutils python
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="http://linux-usb.sourceforge.net/"
-SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="python zlib"
-
-RDEPEND="virtual/libusb:1
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- sys-apps/hwids"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-stdint.patch
-
- if use python; then
- python_convert_shebangs 2 lsusb.py
- sed -i -e '/^usbids/s:/usr/share:/usr/share/misc:' lsusb.py || die
- fi
-}
-
-src_configure() {
- econf \
- --datarootdir="${EPREFIX}/usr/share" \
- --datadir="${EPREFIX}/usr/share/misc" \
- --disable-usbids \
- $(use_enable zlib)
-}
-
-src_install() {
- default
- newdoc usbhid-dump/NEWS NEWS.usbhid-dump
-
- use python || rm -f "${ED}"/usr/bin/lsusb.py
-
- newbin "${FILESDIR}"/usbmodules.sh usbmodules
-}
-
-pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 006 ]]; then
- elog "The 'network-cron' USE flag is gone; if you want a more up-to-date"
- elog "usb.ids file, you should use sys-apps/hwids-99999999 (live ebuild)."
- fi
-}