summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-29 21:31:21 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-29 21:31:21 +0000
commit8b692cb44900c0af0c6724a9a392cd210ed3ed4c (patch)
tree8215741904cd726930c5bca915edf51c7e4da5e2 /sys-apps/util-linux/util-linux-9999.ebuild
parentMake sure we test the newly compiled version #215359. (diff)
downloadgentoo-2-8b692cb44900c0af0c6724a9a392cd210ed3ed4c.tar.gz
gentoo-2-8b692cb44900c0af0c6724a9a392cd210ed3ed4c.tar.bz2
gentoo-2-8b692cb44900c0af0c6724a9a392cd210ed3ed4c.zip
Add support for USE=unicode and USE=slang #208976. Update loop-aes cruft #206331.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 18190ac0da34..a09b6b6f7c72 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.5 2007/08/28 14:03:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.6 2008/03/29 21:31:21 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
inherit eutils
@@ -15,19 +15,21 @@ HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
else
- SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2"
+ SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
+ loop-aes? ( http://loop-aes.sourceforge.net/loop-AES/loop-AES-v3.2c.tar.bz2 )"
fi
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="nls old-linux selinux"
+IUSE="crypt loop-aes nls old-linux selinux slang unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
>=sys-libs/ncurses-5.2-r2
>=sys-fs/e2fsprogs-1.34
- selinux? ( sys-libs/libselinux )"
+ selinux? ( sys-libs/libselinux )
+ slang? ( sys-libs/slang )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
virtual/os-headers"
@@ -39,6 +41,7 @@ src_unpack() {
./autogen.sh || die
else
unpack ${A}
+ use loop-aes && epatch "${WORKDIR}"/loop-AES-*/util-linux-ng-*.diff
fi
}
@@ -63,7 +66,9 @@ src_compile() {
--disable-wall \
--enable-write \
--without-pam \
+ $(use unicode || echo --with-ncurses) \
$(use_with selinux) \
+ $(use_with slang) \
|| die "configure failed"
emake || die "emake failed"
}
@@ -71,4 +76,9 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "install failed"
dodoc AUTHORS NEWS README* TODO docs/*
+
+ if use crypt ; then
+ newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
+ newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
+ fi
}