summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-02 17:10:30 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-02 17:10:30 +0000
commitab9cdd91d48875135409fb078723737951cd9a10 (patch)
treef401ca860c7bf724ebd005e0c3d891b82c7a7567 /sys-apps/which
parent*** empty log message *** (diff)
downloadgentoo-2-ab9cdd91d48875135409fb078723737951cd9a10.tar.gz
gentoo-2-ab9cdd91d48875135409fb078723737951cd9a10.tar.bz2
gentoo-2-ab9cdd91d48875135409fb078723737951cd9a10.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/which')
-rw-r--r--sys-apps/which/files/digest1
-rw-r--r--sys-apps/which/which-2.11-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/which/files/digest b/sys-apps/which/files/digest
new file mode 100644
index 000000000000..3b5ad0af2dca
--- /dev/null
+++ b/sys-apps/which/files/digest
@@ -0,0 +1 @@
+MD5 f4f245abb6cf848ba3642d7da57be905 which-2.11.tar.gz
diff --git a/sys-apps/which/which-2.11-r1.ebuild b/sys-apps/which/which-2.11-r1.ebuild
new file mode 100644
index 000000000000..409eb2c85b26
--- /dev/null
+++ b/sys-apps/which/which-2.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.11-r1.ebuild,v 1.1 2000/08/02 17:07:16 achim Exp $
+
+P=which-2.11
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="sys-apps"
+DESCRIPTION="Prints out location of specified executables that are in your path"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/which/${P}"
+
+src_compile() {
+ ./configure --prefix=/usr
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/tilde
+ cp shell.c shell.c.orig
+ echo "#define NULL ( 0L )" > shell.c
+ cat shell.c.orig >> shell.c
+}
+
+src_install() {
+ into /usr
+ dobin which
+ doman which.1
+ doinfo which.info
+ dodoc AUTHORS COPYING EXAMPLES NEWS README*
+}
+