summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-09-27 20:01:06 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-09-27 20:01:06 +0000
commit5059029780f0960e2acc1d6c5569115323884f40 (patch)
treea2753216e371e65b42dc5d349471975bf6bcb713 /sys-apps/xfsdump
parentmasked updated XFS utilities thanks to Hanno (diff)
downloadgentoo-2-5059029780f0960e2acc1d6c5569115323884f40.tar.gz
gentoo-2-5059029780f0960e2acc1d6c5569115323884f40.tar.bz2
gentoo-2-5059029780f0960e2acc1d6c5569115323884f40.zip
updated XFS utils and masked thanks to Hanno
Diffstat (limited to 'sys-apps/xfsdump')
-rw-r--r--sys-apps/xfsdump/ChangeLog9
-rw-r--r--sys-apps/xfsdump/files/digest-xfsdump-2.1.51
-rw-r--r--sys-apps/xfsdump/xfsdump-2.1.5.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/sys-apps/xfsdump/ChangeLog b/sys-apps/xfsdump/ChangeLog
index 505dd17051de..0ca01e088292 100644
--- a/sys-apps/xfsdump/ChangeLog
+++ b/sys-apps/xfsdump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/xfsdump
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/ChangeLog,v 1.3 2002/07/21 21:18:38 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/ChangeLog,v 1.4 2002/09/27 20:01:06 bcowan Exp $
+
+*xfsdump-2.1.5 (27 Sep 2002)
+
+ 27 Sep 2002; Brad Cowan <bcowan@gentoo.org> xfsdump-2.1.5.ebuild
+ files/digest-xfsdump-2.1.5 :
+
+ version bump thanks to Hanno Boeck <hanno@gentoo.org>
*xfsdump-20020330.ebuild (14 July 2002)
diff --git a/sys-apps/xfsdump/files/digest-xfsdump-2.1.5 b/sys-apps/xfsdump/files/digest-xfsdump-2.1.5
new file mode 100644
index 000000000000..11b80d9a53d7
--- /dev/null
+++ b/sys-apps/xfsdump/files/digest-xfsdump-2.1.5
@@ -0,0 +1 @@
+MD5 e76b8238dbc50d4c72fca1c167035f02 xfsdump-2.1.5.src.tar.gz 545577
diff --git a/sys-apps/xfsdump/xfsdump-2.1.5.ebuild b/sys-apps/xfsdump/xfsdump-2.1.5.ebuild
new file mode 100644
index 000000000000..417bc6ff2068
--- /dev/null
+++ b/sys-apps/xfsdump/xfsdump-2.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/xfsdump-2.1.5.ebuild,v 1.1 2002/09/27 20:01:06 bcowan Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs dump/restore utilities"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs sys-apps/xfsprogs sys-apps/dmapi sys-apps/attr"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ # 5) We now fix some absolute path symlinks in various makefiles
+ local x
+ for x in dump restore
+ do
+ cp ${x}/Makefile ${x}/Makefile.orig
+ sed -e 's:$(INSTALL) -S $(PKG_.*_DIR)/\(.*\) \(.*/.*\):$(INSTALL) -S ../../sbin/\1 \2:' ${x}/Makefile.orig > ${x}/Makefile
+ done
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}