summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-02 17:39:05 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-02 17:39:05 +0000
commit159daf94991be7b5474aaed687e73c0eecaff7e2 (patch)
tree67255154c6944b488e86431caa736fe4fb75c66f /sys-apps/xinetd/xinetd-2.3.13.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-159daf94991be7b5474aaed687e73c0eecaff7e2.tar.gz
gentoo-2-159daf94991be7b5474aaed687e73c0eecaff7e2.tar.bz2
gentoo-2-159daf94991be7b5474aaed687e73c0eecaff7e2.zip
Version bumped.
Diffstat (limited to 'sys-apps/xinetd/xinetd-2.3.13.ebuild')
-rw-r--r--sys-apps/xinetd/xinetd-2.3.13.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/xinetd/xinetd-2.3.13.ebuild b/sys-apps/xinetd/xinetd-2.3.13.ebuild
new file mode 100644
index 000000000000..2561306bbcb9
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.13.ebuild,v 1.1 2004/02/02 17:38:44 mholzer Exp $
+
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~ia64 ~ppc64"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${DEPEND} dev-lang/perl"
+
+PROVIDE="virtual/inetd"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ # the --with-inet6 is now obsolete. Services will default to IPv4 unless configured otherwise.
+
+ econf --with-loadavg ${myconf}
+
+ # Fix CFLAGS
+ sed -i -e "/^CFLAGS/s/+=/=/" Makefile
+
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe xinetd/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/xinetd.conf xinetd.conf.default || die
+ dodoc AUDIT INSTALL README TODO CHANGELOG COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/etc.xinetd.d/* || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xinetd.rc6 xinetd || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/xinetd.confd xinetd || die
+ insinto /etc ; doins ${FILESDIR}/xinetd.conf || die
+}
+
+pkg_postinst(){
+ einfo "This ebuild introduces the /etc/xinetd.d includedir with a default"
+ einfo "/etc/xinetd.conf file. Check your config files if you're upgrading from an older"
+ einfo "ebuild version. You should browse /etc/xinetd.conf and the files in /etc/xinetd.d."
+ ewarn
+ ewarn "PLEASE NOTE: Everything is off by default with access restricted to localhost."
+ ewarn
+ einfo "Check /etc/conf.d/xinetd for the startup options."
+ echo ""
+}