summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-09-01 21:10:02 +0000
committerZac Medico <zmedico@gentoo.org>2012-09-01 21:10:02 +0000
commit0f04c68e4e9ceeb57d097e30e1f8b33cd300e36e (patch)
tree09a32229a8b9581e43428a3a6254f060aca89197 /sys-apps
parentRemoved Files: vmware-mod.eclass vmware.eclass (diff)
downloadgentoo-2-0f04c68e4e9ceeb57d097e30e1f8b33cd300e36e.tar.gz
gentoo-2-0f04c68e4e9ceeb57d097e30e1f8b33cd300e36e.tar.bz2
gentoo-2-0f04c68e4e9ceeb57d097e30e1f8b33cd300e36e.zip
Revert libdir changes in existing ebuilds, in order to avoid possible issues when re-installing those versions on multilib systems. Revision bump latest versions with the libdir changes, which is necessary in order to avoid mentioned issues.
(Portage version: 2.2.0_alpha123_p22/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog14
-rw-r--r--sys-apps/portage/portage-2.1.11.12-r1.ebuild (renamed from sys-apps/portage/portage-2.1.11.12.ebuild)2
-rw-r--r--sys-apps/portage/portage-2.1.11.9.ebuild13
-rw-r--r--sys-apps/portage/portage-2.1.6.7_p1.ebuild21
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha120.ebuild13
-rw-r--r--sys-apps/portage/portage-2.2.0_alpha123-r1.ebuild (renamed from sys-apps/portage/portage-2.2.0_alpha123.ebuild)2
6 files changed, 47 insertions, 18 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index df8f725280f5..27fd9f1f54d0 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1082 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1083 2012/09/01 21:10:02 zmedico Exp $
+
+*portage-2.1.11.12-r1 (01 Sep 2012)
+*portage-2.2.0_alpha123-r1 (01 Sep 2012)
+
+ 01 Sep 2012; Zac Medico <zmedico@gentoo.org> +portage-2.1.11.12-r1.ebuild,
+ +portage-2.2.0_alpha123-r1.ebuild, -portage-2.1.11.12.ebuild,
+ -portage-2.2.0_alpha123.ebuild, portage-2.1.11.9.ebuild,
+ portage-2.1.6.7_p1.ebuild, portage-2.2.0_alpha120.ebuild:
+ Revert libdir changes in existing ebuilds, in order to avoid possible issues
+ when re-installing those versions on multilib systems. Revision bump latest
+ versions with the libdir changes, which is necessary in order to avoid
+ mentioned issues.
01 Sep 2012; Zac Medico <zmedico@gentoo.org> portage-2.1.11.12.ebuild,
portage-2.1.11.9.ebuild, portage-2.1.6.7_p1.ebuild,
diff --git a/sys-apps/portage/portage-2.1.11.12.ebuild b/sys-apps/portage/portage-2.1.11.12-r1.ebuild
index 08c2878c3cbe..f1a1462ee12f 100644
--- a/sys-apps/portage/portage-2.1.11.12.ebuild
+++ b/sys-apps/portage/portage-2.1.11.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.12.ebuild,v 1.2 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.12-r1.ebuild,v 1.1 2012/09/01 21:10:02 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
diff --git a/sys-apps/portage/portage-2.1.11.9.ebuild b/sys-apps/portage/portage-2.1.11.9.ebuild
index fca770d18653..80079c5817c7 100644
--- a/sys-apps/portage/portage-2.1.11.9.ebuild
+++ b/sys-apps/portage/portage-2.1.11.9.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.9.ebuild,v 1.9 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.11.9.ebuild,v 1.10 2012/09/01 21:10:02 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
EAPI=2
-inherit eutils python
+inherit eutils multilib python
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
@@ -98,6 +98,10 @@ current_python_has_xattr() {
}
pkg_setup() {
+ # Bug #359731 - Die early if get_libdir fails.
+ [[ -z $(get_libdir) ]] && \
+ die "get_libdir returned an empty string"
+
if use python2 && use python3 ; then
ewarn "Both python2 and python3 USE flags are enabled, but only one"
ewarn "can be in the shebangs. Using python3."
@@ -217,6 +221,7 @@ src_install() {
emake DESTDIR="${D}" \
sysconfdir="/etc" \
prefix="/usr" \
+ libdir="/usr/$(get_libdir)" \
install || die
# Use dodoc for compression, since the Makefile doesn't do that.
@@ -277,9 +282,9 @@ pkg_preinst() {
pkg_postinst() {
# Compile all source files recursively. Any orphans
# will be identified and removed in postrm.
- python_mod_optimize /usr/lib/portage/pym
+ python_mod_optimize /usr/$(get_libdir)/portage/pym
}
pkg_postrm() {
- python_mod_cleanup /usr/lib/portage/pym
+ python_mod_cleanup /usr/$(get_libdir)/portage/pym
}
diff --git a/sys-apps/portage/portage-2.1.6.7_p1.ebuild b/sys-apps/portage/portage-2.1.6.7_p1.ebuild
index 89e754857b34..e75056cbb90f 100644
--- a/sys-apps/portage/portage-2.1.6.7_p1.ebuild
+++ b/sys-apps/portage/portage-2.1.6.7_p1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.6.7_p1.ebuild,v 1.3 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.6.7_p1.ebuild,v 1.4 2012/09/01 21:10:02 zmedico Exp $
-inherit eutils python
+inherit eutils multilib python
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
@@ -64,6 +64,12 @@ done
S="${WORKDIR}"/${PN}-${TARBALL_PV}
S_PL="${WORKDIR}"/${PN}-${PV_PL}
+pkg_setup() {
+ # Bug #359731 - Die early if get_libdir fails.
+ [[ -z $(get_libdir) ]] && \
+ die "get_libdir returned an empty string"
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -113,7 +119,8 @@ src_test() {
}
src_install() {
- local portage_base="/usr/lib/portage"
+ local libdir=$(get_libdir)
+ local portage_base="/usr/${libdir}/portage"
local portage_share_config=/usr/share/portage/config
cd "${S}"/cnf
@@ -184,14 +191,14 @@ src_install() {
dodir /usr/bin
for x in ebuild emerge portageq repoman xpak; do
- dosym ../lib/portage/bin/${x} /usr/bin/${x}
+ dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
done
dodir /usr/sbin
local x
for x in archive-conf dispatch-conf emaint emerge-webrsync env-update \
etc-update fixpackages quickpkg regenworld ; do
- dosym ../lib/portage/bin/${x} /usr/sbin/${x}
+ dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
done
dosym env-update /usr/sbin/update-env
dosym etc-update /usr/sbin/update-etc
@@ -213,7 +220,7 @@ pkg_preinst() {
pkg_postinst() {
# Compile all source files recursively. Any orphans
# will be identified and removed in postrm.
- python_mod_optimize /usr/lib/portage/pym
+ python_mod_optimize /usr/$(get_libdir)/portage/pym
local warning_shown=0
if [ $DOWNGRADE_FROM_2_2 = 0 ] ; then
@@ -252,5 +259,5 @@ pkg_postinst() {
}
pkg_postrm() {
- python_mod_cleanup /usr/lib/portage/pym
+ python_mod_cleanup /usr/$(get_libdir)/portage/pym
}
diff --git a/sys-apps/portage/portage-2.2.0_alpha120.ebuild b/sys-apps/portage/portage-2.2.0_alpha120.ebuild
index 93d6c6003e17..2dfaac1521b4 100644
--- a/sys-apps/portage/portage-2.2.0_alpha120.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha120.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha120.ebuild,v 1.3 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha120.ebuild,v 1.4 2012/09/01 21:10:02 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
EAPI=3
-inherit eutils python
+inherit eutils multilib python
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
@@ -98,6 +98,10 @@ current_python_has_xattr() {
}
pkg_setup() {
+ # Bug #359731 - Die early if get_libdir fails.
+ [[ -z $(get_libdir) ]] && \
+ die "get_libdir returned an empty string"
+
if use python2 && use python3 ; then
ewarn "Both python2 and python3 USE flags are enabled, but only one"
ewarn "can be in the shebangs. Using python3."
@@ -251,6 +255,7 @@ src_install() {
emake DESTDIR="${D}" \
sysconfdir="${EPREFIX}/etc" \
prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
install || die
# Use dodoc for compression, since the Makefile doesn't do that.
@@ -305,7 +310,7 @@ pkg_preinst() {
pkg_postinst() {
# Compile all source files recursively. Any orphans
# will be identified and removed in postrm.
- python_mod_optimize /usr/lib/portage/pym
+ python_mod_optimize /usr/$(get_libdir)/portage/pym
if $WORLD_MIGRATION_UPGRADE && \
grep -q "^@" "${EROOT}/var/lib/portage/world"; then
@@ -336,5 +341,5 @@ pkg_postinst() {
}
pkg_postrm() {
- python_mod_cleanup /usr/lib/portage/pym
+ python_mod_cleanup /usr/$(get_libdir)/portage/pym
}
diff --git a/sys-apps/portage/portage-2.2.0_alpha123.ebuild b/sys-apps/portage/portage-2.2.0_alpha123-r1.ebuild
index 2e9bcf378d24..67a69d878d57 100644
--- a/sys-apps/portage/portage-2.2.0_alpha123.ebuild
+++ b/sys-apps/portage/portage-2.2.0_alpha123-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha123.ebuild,v 1.2 2012/09/01 20:15:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha123-r1.ebuild,v 1.1 2012/09/01 21:10:02 zmedico Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.