summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-05-15 18:25:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-05-15 18:25:40 +0000
commit1348ba55dc64b911c89573189d7b3d304a53e585 (patch)
tree32af5e336b6ff8fe5ee6ab11ee68be9852a4564b /sys-apps
parentVersion bump. Currently masked because of thread-related crashes, tracked in ... (diff)
downloadgentoo-2-1348ba55dc64b911c89573189d7b3d304a53e585.tar.gz
gentoo-2-1348ba55dc64b911c89573189d7b3d304a53e585.tar.bz2
gentoo-2-1348ba55dc64b911c89573189d7b3d304a53e585.zip
Bug #342537: version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/x86info/ChangeLog10
-rw-r--r--sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch13
-rw-r--r--sys-apps/x86info/x86info-1.29.ebuild67
3 files changed, 88 insertions, 2 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 79f68a26ecbf..bf729e3bc3ac 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/x86info
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.30 2010/02/07 19:42:28 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.31 2011/05/15 18:25:40 robbat2 Exp $
+
+*x86info-1.29 (15 May 2011)
+
+ 15 May 2011; Robin H. Johnson <robbat2@gentoo.org> +x86info-1.29.ebuild,
+ +files/x86info-1.29-parallel-make-cleanup.patch:
+ Bug #342537: version bump
07 Feb 2010; Markus Meier <maekke@gentoo.org> x86info-1.25.ebuild:
amd64/x86 stable, bug #301776
diff --git a/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch b/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
new file mode 100644
index 000000000000..54208cab0843
--- /dev/null
+++ b/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
@@ -0,0 +1,13 @@
+diff -Nuar x86info-1.29.orig/Makefile x86info-1.29/Makefile
+--- x86info-1.29.orig/Makefile 2011-04-05 22:54:04.000000000 +0000
++++ x86info-1.29/Makefile 2011-05-15 18:19:42.204228978 +0000
+@@ -12,7 +12,8 @@
+ LSMSR_TMP_HEADERS=AMD/k8.h AMD/fam10h.h AMD/fam11h.h generic_msr.h
+
+ %.h: %.regs scripts/createheader.py
+- python scripts/createheader.py $< `basename $< .regs` >$@
++ python scripts/createheader.py $< `basename $< .regs` >$@.tmp ; \
++ mv $@.tmp $@
+
+ LSMSR_SRC = \
+ lsmsr.c \
diff --git a/sys-apps/x86info/x86info-1.29.ebuild b/sys-apps/x86info/x86info-1.29.ebuild
new file mode 100644
index 000000000000..b9802d5a8c53
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.29.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.29.ebuild,v 1.1 2011/05/15 18:25:40 robbat2 Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.21-pic.patch
+ epatch "${FILESDIR}"/${PN}-1.24-pic.patch #270388
+ epatch "${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
+}
+
+src_compile() {
+ # These flags taken from the 1.29 ebuild
+ append-flags -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls
+ append-ldflags -Wl,-z,relro,-z,now
+ emake x86info lsmsr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin x86info lsmsr || die
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ dodoc TODO README
+ doman x86info.1 lsmsr.8
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_preinst() {
+ if [ -a "${ROOT}"/etc/modules.d/x86info ] && [ ! -a "${ROOT}"/etc/modprobe.d/x86info ] ; then
+ elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
+ mv "${ROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [ -a "${ROOT}"/etc/modprobe.d/x86info ] && [ ! -a "${ROOT}"/etc/modprobe.d/x86info.conf ] ; then
+ elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
+ mv "${ROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}