summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-11 12:17:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-11 12:17:43 +0000
commit1e92508c8548013443d7ab796dabe76d5213c76d (patch)
tree5ebeed61b9a9c2e6272486f457211d8247e4ab5b /sys-apps
parentVersion bump, drop old (diff)
downloadgentoo-2-1e92508c8548013443d7ab796dabe76d5213c76d.tar.gz
gentoo-2-1e92508c8548013443d7ab796dabe76d5213c76d.tar.bz2
gentoo-2-1e92508c8548013443d7ab796dabe76d5213c76d.zip
Version bump to development series. File dbus-1.4.0-asneeded.patch fails to apply and should be looked into before keywording.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog9
-rw-r--r--sys-apps/dbus/dbus-1.5.12.ebuild187
-rw-r--r--sys-apps/dbus/metadata.xml11
3 files changed, 202 insertions, 5 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index ce14dddaa072..04c82d58f6e3 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dbus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.335 2012/05/05 21:51:18 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.336 2012/05/11 12:17:43 ssuominen Exp $
+
+*dbus-1.5.12 (11 May 2012)
+
+ 11 May 2012; Samuli Suominen <ssuominen@gentoo.org> +dbus-1.5.12.ebuild,
+ metadata.xml:
+ Version bump to development series. File dbus-1.4.0-asneeded.patch fails to
+ apply and should be looked into before keywording.
05 May 2012; Brent Baude <ranger@gentoo.org> dbus-1.4.20.ebuild:
Marking dbus-1.4.20 ppc for bug 412535
diff --git a/sys-apps/dbus/dbus-1.5.12.ebuild b/sys-apps/dbus/dbus-1.5.12.ebuild
new file mode 100644
index 000000000000..6a9e66a25927
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.5.12.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.5.12.ebuild,v 1.1 2012/05/11 12:17:43 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils linux-info multilib flag-o-matic python systemd virtualx
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( AFL-2.1 GPL-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc selinux static-libs systemd test X"
+
+RDEPEND=">=dev-libs/expat-2
+ selinux? (
+ sec-policy/selinux-dbus
+ sys-libs/libselinux
+ )
+ systemd? ( >=sys-apps/systemd-32 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )
+ test? (
+ >=dev-libs/glib-2.24
+ dev-lang/python:2.7
+ )"
+
+# out of sources build directory
+BD=${WORKDIR}/${P}-build
+# out of sources build dir for make check
+TBD=${WORKDIR}/${P}-tests-build
+
+pkg_setup() {
+ enewgroup messagebus
+ enewuser messagebus -1 -1 -1 messagebus
+
+ # FIXME: Test suite fails with Python 3.2 (last checked: 1.4.20)
+ if use test; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~EPOLL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Tests were restricted because of this
+ sed -i \
+ -e 's/.*bus_dispatch_test.*/printf ("Disabled due to excess noise\\n");/' \
+ -e '/"dispatch"/d' \
+ bus/test-main.c || die
+
+ # required for asneeded patch but also for bug 263909, cross-compile so
+ # don't remove eautoreconf
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # so we can get backtraces from apps
+ append-flags -rdynamic
+
+ # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
+ # not on an SELinux profile.
+ myconf=(
+ --localstatedir=/var
+ --docdir=/usr/share/doc/${PF}
+ --htmldir=/usr/share/doc/${PF}/html
+ $(use_enable static-libs static)
+ $(use_enable debug verbose-mode)
+ --disable-asserts
+ --disable-checks
+ $(use_enable selinux)
+ $(use_enable selinux libaudit)
+ $(use_enable kernel_linux inotify)
+ $(use_enable kernel_FreeBSD kqueue)
+ $(use_enable systemd)
+ --disable-embedded-tests
+ --disable-modular-tests
+ $(use_enable debug stats)
+ --with-xml=expat
+ --with-session-socket-dir=/tmp
+ --with-system-pid-file=/var/run/dbus.pid
+ --with-system-socket=/var/run/dbus/system_bus_socket
+ --with-dbus-user=messagebus
+ $(use_with X x)
+ "$(systemd_with_unitdir)"
+ )
+
+ mkdir "${BD}"
+ cd "${BD}"
+ einfo "Running configure in ${BD}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" \
+ $(use_enable doc xml-docs) \
+ $(use_enable doc doxygen-docs)
+
+ if use test; then
+ mkdir "${TBD}"
+ cd "${TBD}"
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" \
+ $(use_enable test asserts) \
+ $(use_enable test checks) \
+ $(use_enable test embedded-tests) \
+ $(has_version dev-libs/dbus-glib && echo --enable-modular-tests)
+ fi
+}
+
+src_compile() {
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ cd "${BD}"
+ einfo "Running make in ${BD}"
+ emake
+
+ if use test; then
+ cd "${TBD}"
+ einfo "Running make in ${TBD}"
+ emake
+ fi
+}
+
+src_test() {
+ cd "${TBD}"
+ DBUS_VERBOSE=1 Xemake -j1 check
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/dbus.initd dbus
+
+ if use X; then
+ # dbus X session script (#77504)
+ # turns out to only work for GDM (and startx). has been merged into
+ # other desktop (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}"/80-dbus
+ fi
+
+ # needs to exist for dbus sessions to launch
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/system.d
+ keepdir /etc/dbus-1/session.d
+ keepdir /var/lib/dbus # See pkg_postinst() for symlink creation
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+
+ cd "${BD}"
+ emake DESTDIR="${D}" install
+
+ find "${ED}" -type f -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "Some applications require a session bus in addition to the system"
+ elog "bus. Please see \`man dbus-launch\` for more information."
+ elog
+ ewarn "You must restart D-Bus \`/etc/init.d/dbus restart\` to run"
+ ewarn "the new version of the daemon."
+ ewarn "Don't do this while X is running because it will restart your X as well."
+
+ # Ensure unique id is generated and put it in /etc wrt #370451 but symlink
+ # for DBUS_MACHINE_UUID_FILE (see tools/dbus-launch.c) and reverse
+ # dependencies with hardcoded paths (although the known ones got fixed already)
+ dbus-uuidgen --ensure="${EROOT}"/etc/machine-id
+ ln -sf "${EROOT}"/etc/machine-id "${EROOT}"/var/lib/dbus/machine-id
+}
diff --git a/sys-apps/dbus/metadata.xml b/sys-apps/dbus/metadata.xml
index 9879e83b822e..4e9b563738fe 100644
--- a/sys-apps/dbus/metadata.xml
+++ b/sys-apps/dbus/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>freedesktop</herd>
- <maintainer>
- <email>freedesktop-bugs@gentoo.org</email>
- </maintainer>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='systemd'>Build with <pkg>sys-apps/systemd</pkg> at_console support</flag>
+ </use>
</pkgmetadata>