summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-09-14 04:30:27 +0000
committerDonny Davies <woodchip@gentoo.org>2002-09-14 04:30:27 +0000
commit206da35c972b2820fc0abf7713c833e15126feba (patch)
treed1fe691301f44799cada86044754c945d0c784f8 /sys-apps
parentmask-in latest parted; mask-out latest stable mysql (diff)
downloadgentoo-2-206da35c972b2820fc0abf7713c833e15126feba.tar.gz
gentoo-2-206da35c972b2820fc0abf7713c833e15126feba.tar.bz2
gentoo-2-206da35c972b2820fc0abf7713c833e15126feba.zip
chase latest, add libreiserfs, #7340
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/parted/ChangeLog14
-rw-r--r--sys-apps/parted/files/digest-parted-1.6.31
-rw-r--r--sys-apps/parted/parted-1.6.3.ebuild35
3 files changed, 43 insertions, 7 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 63c58dd29a33..c9661a2ca931 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/parted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.6 2002/07/14 19:20:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.7 2002/09/14 04:30:27 woodchip Exp $
+
+*parted-1.6.3 (14 Sep 2002)
+
+ 14 Sep 2002; Donny Davies <woodchip@gentoo.org> :
+ Chase latest release. Added the libreiserfs support.
*parted-1.6.1 (8 Jun 2002)
@@ -8,7 +13,6 @@
Added KEYWORDS.
8 Jun 2002; Donny Davies <woodchip@gentoo.org> :
-
New 1.6 release + small install patch. This one can use dev-libs/progsreiserfs
optionally at runtime; not installed per default at the moment. Testing/feedback
on this welcome.
@@ -19,7 +23,6 @@
Added LICENSE, KEYWORDS, SLOT.
16 Apr 2002; Seemant Kulleen <seemant@gentoo.org> parted-1.4.24-r3.ebuild :
-
Closes bug #1690 and related bugs. Thanks to everyone for the patches and
fixes.
@@ -29,20 +32,17 @@
Added LICENSE, KEYWORDS, SLOT.
29 Mar 2002; Seemant Kulleen <seemant@gentoo.org> parted-1.4.24-r2.ebuild :
-
Matthew Kennedy submitted some fixes for USE flag based compilation -- to
explicitly enable if in USE and explicitly disable if not.
*parted-1.4.24-r1 (27 Mar 2002)
27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> parted-1.4.24-r1.ebuild :
-
man page/LFH fixes submitted by Matthew Kennedy.
*parted-1.4.24 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/sys-apps/parted/files/digest-parted-1.6.3 b/sys-apps/parted/files/digest-parted-1.6.3
new file mode 100644
index 000000000000..b0f2f1273684
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.6.3
@@ -0,0 +1 @@
+MD5 6c2ed5bc8c8cde7580483a6dc0af78bb parted-1.6.3.tar.gz 1156134
diff --git a/sys-apps/parted/parted-1.6.3.ebuild b/sys-apps/parted/parted-1.6.3.ebuild
new file mode 100644
index 000000000000..4eb9aa88ae92
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.3.ebuild,v 1.1 2002/09/14 04:30:27 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/parted"
+KEYWORDS="x86 ppc sparc sparc64"
+DEPEND="virtual/glibc
+ >=sys-apps/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+RDEPEND="${DEPEND} =dev-libs/progsreiserfs-0.3.0*"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use readline || myconf="${myconf} --without-readline"
+ [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --disable-debug"
+ use static && myconf="${myconf} --enable-all-static"
+ econf --target=${CHOST} ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}