summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-09-18 23:48:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-09-18 23:48:48 +0000
commit24fd3d8b52a6345dfc1876d4c5bec6b7153565bb (patch)
tree4c1bcdadb28ec7c67351d93fc1aa77c8421189e1 /sys-apps
parentMask sys-apps/elfix while testing experimental utility (diff)
downloadgentoo-2-24fd3d8b52a6345dfc1876d4c5bec6b7153565bb.tar.gz
gentoo-2-24fd3d8b52a6345dfc1876d4c5bec6b7153565bb.tar.bz2
gentoo-2-24fd3d8b52a6345dfc1876d4c5bec6b7153565bb.zip
Version bump, adds paxctl-ng
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/elfix/ChangeLog5
-rw-r--r--sys-apps/elfix/elfix-0.2.0.ebuild27
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 7dbbaecc4882..fde9b9cd7f7c 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,5 +1,10 @@
+*elfix-0.2.0 (18 Sep 2011)
+
+ 18 Sep 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.2.0.ebuild:
+ Version bump, adds paxctl-ng
+
13 Sep 2011; Anthony G. Basile <blueness@gentoo.org> -elfix-0.1.1.ebuild:
Removed deprecated version
diff --git a/sys-apps/elfix/elfix-0.2.0.ebuild b/sys-apps/elfix/elfix-0.2.0.ebuild
new file mode 100644
index 000000000000..2c66f7f6219b
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.2.0.ebuild,v 1.1 2011/09/18 23:48:48 blueness Exp $
+
+EAPI=4
+
+DESCRIPTION="Tool to query or clear the ELF GNU_STACK executable flag"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-libs/elfutils
+ test? ( dev-lang/yasm )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}