summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 00:05:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 00:05:43 +0000
commit28c9be73c278d0d20ea9dad321bdd85b722bdbb9 (patch)
tree3adfb5ded5d50333086c583aeedddd5bd3a1d772 /sys-apps
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-28c9be73c278d0d20ea9dad321bdd85b722bdbb9.tar.gz
gentoo-2-28c9be73c278d0d20ea9dad321bdd85b722bdbb9.tar.bz2
gentoo-2-28c9be73c278d0d20ea9dad321bdd85b722bdbb9.zip
fix for 2.4 linux-headers #46978
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute/ChangeLog3
-rw-r--r--sys-apps/iproute/iproute-20010824-r5.ebuild17
2 files changed, 14 insertions, 6 deletions
diff --git a/sys-apps/iproute/ChangeLog b/sys-apps/iproute/ChangeLog
index 92751146c165..57e1fb6bba63 100644
--- a/sys-apps/iproute/ChangeLog
+++ b/sys-apps/iproute/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-apps/iproute
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.33 2004/04/06 15:19:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.34 2004/04/07 00:05:43 vapier Exp $
*iproute-20010824-r5 (06 Apr 2004)
@@ -12,6 +12,7 @@
#40230 by Sebastian Werner - Use system pkt_sched.h instead of bundled.
#40510 by valli - Use system glibc headers instead of bundled.
#45274 by David Pufer - Add HFSC support.
+ #46978 by Seemant Kulleen - Add a little hack to handle 2.4 linux-headers.
25 Mar 2004; Joshua Kinard <kumba@gentoo.org> iproute-20010824-r4.ebuild:
Marked stable on mips.
diff --git a/sys-apps/iproute/iproute-20010824-r5.ebuild b/sys-apps/iproute/iproute-20010824-r5.ebuild
index caaab3b88b37..aace5263a8ed 100644
--- a/sys-apps/iproute/iproute-20010824-r5.ebuild
+++ b/sys-apps/iproute/iproute-20010824-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824-r5.ebuild,v 1.2 2004/04/06 17:19:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824-r5.ebuild,v 1.3 2004/04/07 00:05:43 vapier Exp $
-inherit eutils
+inherit eutils flag-o-matic
DEBIANPATCH="${P/-/_}-13.diff.gz"
SRCFILE="iproute2-2.4.7-now-ss${PV/20}.tar.gz"
@@ -38,13 +38,19 @@ src_unpack() {
# Enable HFSC scheduler #45274
if [ ! -z "`grep tc_service_curve ${ROOT}/usr/include/linux/pkt_sched.h`" ] ; then
epatch ${FILESDIR}/${PV}-hfsc.patch
- epatch ${FILESDIR}/${PV}-rates-1024-fix.patch
else
ewarn "Your linux-headers in /usr/include/linux are too old to"
ewarn "support the HFSC scheduler. It has been disabled."
fi
+ epatch ${FILESDIR}/${PV}-rates-1024-fix.patch
rm include/linux/pkt_sched.h
+ # Now a little hack to handle 2.4.x headers and stupid defines ...
+ if has_version '<sys-kernel/linux-headers-2.8' ; then
+ echo '#define __constant_htons(x) htons(x)' >> include-glibc/glibc-bugs.h
+ append-flags -D_LINUX_BYTEORDER_LITTLE_ENDIAN_H -D_LINUX_BYTEORDER_BIG_ENDIAN_H
+ fi
+
# Fix local DoS exploit #34294
epatch ${FILESDIR}/${PV}-local-exploit-fix.patch
@@ -74,12 +80,13 @@ src_install() {
dosbin ifcfg ip routef routel rtacct rtmon rtpr || die "dosbin * failed"
cd ${S}/tc
dosbin tc || die "dosbin tc failed"
+ cd ${S}
#install Debian man pages
- doman ${S}/debian/manpages/*.[1-9]
+ doman debian/manpages/*.[1-9]
- docinto examples/diffserv ; dodoc examples/diffserv/*
docinto examples ; dodoc examples/*
+ docinto examples/diffserv ; dodoc examples/diffserv/*
dodir /etc/iproute2
insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
if use doc && [ -n "`ls doc/*.ps`" ] ; then