summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-10-28 11:09:21 +0000
committerMike Frysinger <vapier@gentoo.org>2012-10-28 11:09:21 +0000
commit35c361c05120271037d72789f2a612db2312f555 (patch)
treef2f03346ef7840e8c44a631f48a8968770d43f83 /sys-apps
parentVersion bump. Drop USE=doc, it did nothing useful. (diff)
downloadgentoo-2-35c361c05120271037d72789f2a612db2312f555.tar.gz
gentoo-2-35c361c05120271037d72789f2a612db2312f555.tar.bz2
gentoo-2-35c361c05120271037d72789f2a612db2312f555.zip
Install daily cronjob for building caches #289884 by C W Rose.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man-db/ChangeLog8
-rw-r--r--sys-apps/man-db/files/man-db.cron10
-rw-r--r--sys-apps/man-db/man-db-2.6.3-r1.ebuild65
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 6ba152ae82a1..8e02a0d40e8f 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.32 2012/09/19 04:03:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.33 2012/10/28 11:09:21 vapier Exp $
+
+*man-db-2.6.3-r1 (28 Oct 2012)
+
+ 28 Oct 2012; Mike Frysinger <vapier@gentoo.org> +files/man-db.cron,
+ +man-db-2.6.3-r1.ebuild:
+ Install daily cronjob for building caches #289884 by C W Rose.
*man-db-2.6.3 (19 Sep 2012)
diff --git a/sys-apps/man-db/files/man-db.cron b/sys-apps/man-db/files/man-db.cron
new file mode 100644
index 000000000000..ced63900fca6
--- /dev/null
+++ b/sys-apps/man-db/files/man-db.cron
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# Use same perms/settings as the ebuild.
+if [ ! -d /var/cache/man ]; then
+ mkdir -p /var/cache/man
+ chown man:root /var/cache/man
+ chmod 2755 /var/cache/man
+fi
+
+exec nice mandb --quiet
diff --git a/sys-apps/man-db/man-db-2.6.3-r1.ebuild b/sys-apps/man-db/man-db-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..6dbdf58b6606
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.6.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.3-r1.ebuild,v 1.1 2012/10/28 11:09:21 vapier Exp $
+
+EAPI="4"
+
+inherit eutils user
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb +gdbm nls static-libs zlib"
+
+RDEPEND="dev-libs/libpipeline
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --enable-setuid \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ use static-libs || find "${ED}"/usr/ -name '*.la' -delete
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+
+ keepdir /var/cache/man
+ fowners man:root /var/cache/man
+ fperms 2755 /var/cache/man
+}
+
+pkg_preinst() {
+ if [[ -f "${ROOT}"var/cache/man/whatis ]]; then
+ einfo "Cleaning ${ROOT}var/cache/man from sys-apps/man"
+ find "${ROOT}"var/cache/man -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+}