summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-05 03:44:57 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-05 03:44:57 +0000
commit48abfab61d5b31c0be89a28c1a26552f05d6a24e (patch)
tree3ad2c77b79f9efc12a877d1bd15d85a78d569d64 /sys-apps
parentMarked ppc stable for bug #291484. (diff)
downloadgentoo-2-48abfab61d5b31c0be89a28c1a26552f05d6a24e.tar.gz
gentoo-2-48abfab61d5b31c0be89a28c1a26552f05d6a24e.tar.bz2
gentoo-2-48abfab61d5b31c0be89a28c1a26552f05d6a24e.zip
Version bump #296785 by Michał Guminiak.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/ChangeLog10
-rw-r--r--sys-apps/smartmontools/smartmontools-5.39.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 8da8de44d474..145d415000f9 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.84 2009/10/11 00:43:58 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.85 2010/01/05 03:44:57 vapier Exp $
+
+*smartmontools-5.39 (05 Jan 2010)
+
+ 05 Jan 2010; Mike Frysinger <vapier@gentoo.org>
+ +smartmontools-5.39.ebuild:
+ Version bump #296785 by Michał Guminiak.
11 Oct 2009; Mike Frysinger <vapier@gentoo.org> files/smartd.rc:
Switch killall to ssd.
diff --git a/sys-apps/smartmontools/smartmontools-5.39.ebuild b/sys-apps/smartmontools/smartmontools-5.39.ebuild
new file mode 100644
index 000000000000..ecc565dc7019
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.39.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.39.ebuild,v 1.1 2010/01/05 03:44:57 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal"
+
+RDEPEND="!minimal? ( virtual/mailx )"
+DEPEND=""
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ econf \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}