summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-16 21:34:43 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-16 21:34:43 +0000
commit493ec69680fb6733751acba0760db8aa3bdebe14 (patch)
tree9521fc26536e44fdd2ac919a1b996daf7478e08a /sys-apps
parentupdate metadata (diff)
downloadgentoo-2-493ec69680fb6733751acba0760db8aa3bdebe14.tar.gz
gentoo-2-493ec69680fb6733751acba0760db8aa3bdebe14.tar.bz2
gentoo-2-493ec69680fb6733751acba0760db8aa3bdebe14.zip
Drop bindnow-flags #227019 by Diego Pettenò. Switch to emake. Fix ROOT support in pkg_postinst. Respect CPPFLAGS/LDFLAGS.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/utempter/ChangeLog9
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-build.patch11
-rw-r--r--sys-apps/utempter/utempter-0.5.5.6.ebuild44
3 files changed, 35 insertions, 29 deletions
diff --git a/sys-apps/utempter/ChangeLog b/sys-apps/utempter/ChangeLog
index 2474c9017889..4dba9ccc93d2 100644
--- a/sys-apps/utempter/ChangeLog
+++ b/sys-apps/utempter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/utempter
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.43 2007/12/25 15:19:21 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.44 2008/06/16 21:34:42 vapier Exp $
+
+ 16 Jun 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/utempter-0.5.5.6-build.patch, utempter-0.5.5.6.ebuild:
+ Drop bindnow-flags #227019 by Diego Pettenò. Switch to emake. Fix ROOT
+ support in pkg_postinst. Respect CPPFLAGS/LDFLAGS.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing seemant from metadata.xml as per #202469.
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-build.patch b/sys-apps/utempter/files/utempter-0.5.5.6-build.patch
new file mode 100644
index 000000000000..8fbfb111196f
--- /dev/null
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-build.patch
@@ -0,0 +1,11 @@
+--- Makefile
++++ Makefile
+@@ -37,7 +37,7 @@
+ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR)
+
+ $(SHAREDLIB): utmpintf.os
+- $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
++ $(CC) $(LDFLAGS) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
+
+ utmpintf.o: utmpintf.c utempter.h
+
diff --git a/sys-apps/utempter/utempter-0.5.5.6.ebuild b/sys-apps/utempter/utempter-0.5.5.6.ebuild
index 416f48907bae..a19b9c8b252e 100644
--- a/sys-apps/utempter/utempter-0.5.5.6.ebuild
+++ b/sys-apps/utempter/utempter-0.5.5.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.5.6.ebuild,v 1.14 2007/07/12 05:10:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.5.6.ebuild,v 1.15 2008/06/16 21:34:42 vapier Exp $
-inherit rpm eutils flag-o-matic
+inherit rpm eutils
MY_P=${P%.*}-${PV##*.}
S=${WORKDIR}/${P%.*}
@@ -16,9 +16,6 @@ KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE=""
DEPEND="!virtual/utempter"
-RDEPEND="virtual/libc
- !virtual/utempter"
-
PROVIDE="virtual/utempter"
pkg_setup() {
@@ -27,41 +24,34 @@ pkg_setup() {
src_unpack() {
rpm_src_unpack
- cd ${S}
- epatch ${FILESDIR}/${P}-soname-makefile-fix.patch
- epatch ${FILESDIR}/${P}-no_utmpx.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-soname-makefile-fix.patch
+ epatch "${FILESDIR}"/${P}-no_utmpx.patch
+ epatch "${FILESDIR}"/${P}-build.patch
}
src_compile() {
- append-ldflags $(bindnow-flags)
-
- make RPM_OPT_FLAGS="${CFLAGS}" || die
+ emake RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" || die
}
src_install() {
- make \
+ emake \
RPM_BUILD_ROOT="${D}" \
LIBDIR=/usr/$(get_libdir) \
install || die
- dobin utmp
+ dobin utmp || die
fowners root:utmp /usr/sbin/utempter
fperms 2755 /usr/sbin/utempter
}
pkg_postinst() {
- if [ "${ROOT}" = "/" ]
- then
- if [ -f /var/log/wtmp ]
- then
- chown root:utmp /var/log/wtmp
- chmod 664 /var/log/wtmp
- fi
-
- if [ -f /var/run/utmp ]
- then
- chown root:utmp /var/run/utmp
- chmod 664 /var/run/utmp
- fi
+ if [ -f "${ROOT}"/var/log/wtmp ] ; then
+ chown root:utmp "${ROOT}"/var/log/wtmp
+ chmod 664 "${ROOT}"/var/log/wtmp
+ fi
+ if [ -f "${ROOT}"/var/run/utmp ] ; then
+ chown root:utmp "${ROOT}"/var/run/utmp
+ chmod 664 "${ROOT}"/var/run/utmp
fi
}