summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-24 02:29:04 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-24 02:29:04 +0000
commit4a07f522d4139dbbbd6d6849bc92a08dc7767dd8 (patch)
tree070ab739a2ed2c82ea31f96381c431c1a9fe092b /sys-apps
parentseq: dont parse args if `seq` is available, and add a shell fall back if `jot... (diff)
downloadgentoo-2-4a07f522d4139dbbbd6d6849bc92a08dc7767dd8.tar.gz
gentoo-2-4a07f522d4139dbbbd6d6849bc92a08dc7767dd8.tar.bz2
gentoo-2-4a07f522d4139dbbbd6d6849bc92a08dc7767dd8.zip
Version bump #338432 by Samuli Suominen.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/ChangeLog7
-rw-r--r--sys-apps/mlocate/mlocate-0.23.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/sys-apps/mlocate/ChangeLog b/sys-apps/mlocate/ChangeLog
index ca170c91bd88..6698793ba9f0 100644
--- a/sys-apps/mlocate/ChangeLog
+++ b/sys-apps/mlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/mlocate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.67 2010/09/23 21:28:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/ChangeLog,v 1.68 2010/09/24 02:29:04 vapier Exp $
+
+*mlocate-0.23.1 (24 Sep 2010)
+
+ 24 Sep 2010; Mike Frysinger <vapier@gentoo.org> +mlocate-0.23.1.ebuild:
+ Version bump #338432 by Samuli Suominen.
23 Sep 2010; Markus Meier <maekke@gentoo.org> mlocate-0.22.4.ebuild:
add ~arm, bug #338426
diff --git a/sys-apps/mlocate/mlocate-0.23.1.ebuild b/sys-apps/mlocate/mlocate-0.23.1.ebuild
new file mode 100644
index 000000000000..68b8ab9a9a2d
--- /dev/null
+++ b/sys-apps/mlocate/mlocate-0.23.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.23.1.ebuild,v 1.1 2010/09/24 02:29:04 vapier Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Merging locate is an utility to index and quickly search for files"
+HOMEPAGE="https://fedorahosted.org/mlocate/"
+SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate
+ !sys-apps/rlocate"
+DEPEND="app-arch/xz-utils"
+
+pkg_setup() {
+ enewgroup locate
+}
+
+src_compile() {
+ emake groupname=locate || die
+}
+
+src_install() {
+ emake groupname=locate DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README NEWS
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf || die
+ doins "${FILESDIR}"/mlocate-cron.conf || die
+ fperms 0644 /etc/{updatedb,mlocate-cron}.conf
+
+ insinto /etc/cron.daily
+ newins "${FILESDIR}/mlocate.cron-r2" mlocate
+ fperms 0755 /etc/cron.daily/mlocate
+
+ fowners 0:locate /usr/bin/locate
+ fperms go-r,g+s /usr/bin/locate
+
+ keepdir /var/lib/mlocate
+ chown -R 0:locate "${D}"/var/lib/mlocate
+ fperms 0750 /var/lib/mlocate
+}
+
+pkg_postinst() {
+ elog "Note that the /etc/updatedb.conf file is generic;"
+ elog "Please customize it to your system requirements."
+}